• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

cdrw drive problem

N

npfanz

Guest
#1
I have a plextor 10/24/40A cdrw drive, and I just applied the latest firmware upgrade. Now that I have done so if I put a cd in the drive and try to read it windows explorer crashes. I haven't yet tried to burn a cd in it (I'm too afraid to). Since I upgraded the firmware that just means I'm screwed, right? There is no way to undo that, is there? I emailed their tech support and have yet to hear back from them. I don't hold out much hope because, despite the fact that the firmware upgrade was supposed to fix a whole host of bugs, it specified that "plextor is not responsible for any damage, etc." How can they not be responsible? There were some issues that needed to be fixed, and their fix wrecked my drive. Any ideas?
 
S

Skwowwy

Guest
#2
Firmwares can't be removed, unless you detach the CD-RW, remove all drivers, and attach it again. XP will install its own drivers again.

Or at least, I think that'll work. I may be wrong, though. *isn't a real XP expert like others* XD
 
O

orcas

Guest
#3
firmware...

AFAIK, detaching cdr drive, removing drivers, and attaching again has nothing to do with the firmware...the firmware if permanently saved in any kind of EPROM and will only change if you flash another firmware over it...you have to get the old firmware and flash it again...

orcas
 
N

npfanz

Guest
#4
Yeah I thought I would have to find the old firmware. But as kind of a take off of Skwowwy's suggestion, I just decided to uninstall the hardware through device manager. It was completely on a whim, but it seems to have worked!? I opened device manager, uninstalled the cdrw drive, then restarted. After the restart, it seems to work. But I was never notified that it was reinstalled or anything. Seems very strange but as long as it works I'm happy. Thanks for the advice, guys, I really appreciate the quick replys. This was driving me insane all morning!!!!!!!!

THANKS!!!
 
G

Gouk

Guest
#6
Originally posted by npfanz
Yeah I thought I would have to find the old firmware. But as kind of a take off of Skwowwy's suggestion, I just decided to uninstall the hardware through device manager. It was completely on a whim, but it seems to have worked!? I opened device manager, uninstalled the cdrw drive, then restarted. After the restart, it seems to work. But I was never notified that it was reinstalled or anything. Seems very strange but as long as it works I'm happy. Thanks for the advice, guys, I really appreciate the quick replys. This was driving me insane all morning!!!!!!!!

THANKS!!!
I'm glad you got your problem sorted too :)
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,015
Latest member
oggeytom