• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

CD-RW problems



OK, I've had XP installed for about 2 months, running perfect. I decided to add my CD-RW (Plextor 12/10/40A) from my Win98 machine to my XP one. I have my Hard Drive (master) and CD-Rom (slave) on the primary channel, and the CD-RW on the secondary as master. When I first booted up, XP said "New CD-ROM found, Plextor 12/10/40". I thought it would be fine. But, I have a REALLY odd problem. In Windows Explorer, my CD-RW isn't listed at all. I checked in Device Manager, and it IS there. There are no "?" or "!" next to it. I don't have Nero or ANY burning software installed yet, so I know that's not it. I also have the built in XP recording engine off. I just dont understand why it shows up in Device Manager, but NOT in explorer. Any help would be GREATLY appreciated.



hmmm... just a guess, but reinstall it... and/or goto the places website, and download new drivers
In device manager right click and select properties. What does it say? My guess is it will tell you why it's not working. I don't know why, but when XP knows why something isn't working it will give a blurb about it instead of displaying the little markers we've all come to know an love.

My cure was mini-port drivers for this same problem.

And also, as DAZZ suggested, look for compatible drivers as well as firmware upgrades for your burner. I suggest going that route first because mini-port drivers should only be used if you have IDE related problems. This is of course, but use them as a last resort.


Well, Plextor says the default Windows CD-Rom drivers should work. Also, the frimware is up to date, I did that when it was on my other machine. In device manager, there are no errors or anything. It says "this device is working properly". I enabled the built in cd-r engine for XP, and it still doesn't recognize it as a CD-RW.


I just downloaded and installed the Mini-port drivers from VIA, but that didn't solve the problem. Were those the drivers you were referring to? This is driving me nuts. Thanks for all the help everyone.
If you have the VIA chipset then yes.

Try this (it would work for me sometimes). Put a CD in and leave it there while you boot up. I don't know why that worked for me (and a couple of other folks) but it did. It's not a cure for the problem though, but it's a test to see if your symptoms are similar.

What else? You say you installed the VIA mini-port drivers. I'm guessing they went in ok because you're here. Have you updated to the latest 4-in-1 drivers? I don't know why, but for some reason the VIA chipset just doesn't work well for some of us. If you don't have the latest 4-in-1's, get those in (after you remove the mini-port driver). Try those, and then the mini-ports on top of those.

If you haven't done it yet, create a system restore point. I know the mini-ports alone have crashed some peoples computers. I apologize for not mentioning that before.


Well, I tried installing the 4-in-1 drivers. It told me it had to reboot to complete. When it went to reboot it froze. So, I manually rebooted. But instead of windows booting up, I got some wierd blue screen telling me something like "windows startup has been canceled to prevent hardware damage. Run CHKDSK to scan for HD errors...." Anyway, after running CHKDSK, SCANDISK, and even trying to "Repair" my installation with the XP CD, I still got the same blue screen. So, I re-installed XP completely. The good news is that both my CD-Rom and CD-RW are being detected and everything is working fine. Thanks for all the help.
sorry to hear about the total crash man. I don't know what it is with VIA and them damn 4-in1's. For some people they're a curse and for some they're a blessing. I think i've seen more curses then blessings though. I'm glad you're up and running on all cylinders again. I really hope you didn't lose anything important.


Nope, nothing too important. I backed up most of my important stuff recently, so it'll be ok. Yeah, I've heard the VIA's can be pretty wierd acting. Anyway, thanks for the help everyone.


I had this same problem yesterday with my Plextor 12x10x32. After trying all the things in XP I could think of, I finally swithched the data cable to another one and it cured the problem. I also was having problems getting XP to enable DMA on my Pioneer DVD. It took a reinstalling of the Via Busmaster driver to cure that. I don't know if the 2 are related, just passing on my experience.
I had the same problem with a Plex 16/10/40

I had the latest bios and reflashed to the next version down. That did it for me.

Make sure that your CDrw is master on the second IDE channel. It doesn't like to be slave to anything.

Also, get rid of all burning software and clean the registry of all entries. I finally ended up using EZCD 5.03c with Direct CD and everything works. I had to take off Nero, cloneCD and fireburner.

Also, disable DMA on your drive.

Also, install the ASPI layer from ADaptec. That should do it for you.


The cure for this seems simple... Uninstall the MS update Q309691. The cd burner update... Then go to MS and get it again... Rebbot and cd-burner problems should be gone...


Since installing XP a couple of months ago, I have similar problems to all the above - CD-R not recording, or hanging the machine mid-process. I'm getting really frustrated by it all. I've uninstalled Nero and reinstalled umpteen times to no effect. I don't know how to access the XP built in CD recorder, so haven't been able to uninstall it or disable it (it doesn't work either. Sorry to go on - but I'm flummoxed and frustrated. I've just looked on the MS knowledge base and download areas and can only find a note that MS know that there is a problem with CD-R's - but no patch or otherwise to download. Can anyone out there help? :( :confused:
Nero is said to be causing problems

Uninstall it and clean your registry of any entries. Try installing EZCD creator 5 with theupdate to 5.02c. That one works fine on my machine. If you can find it, there is a 5.1 update to Direct CD that works nicely. I've had no problems once I cleaned out all the other CDR software and used the Roxio stuff. And I'm running an underpowered 233 MHz AMD K6 processor!!! Hope this helps.


Thanks for that, but..... novice that I am, how do I clean out my registry of Nero entries? I've never really tinkered with the registry before, other than peeping inside it once or twice and thinking 'That looks complicated!':eek:
The registry isn't for novices, but it's no harder that editing a text file.

First off, for safety, copy your registry files to a temporary location, in case something messes up. You can always copoy these back to their original location to return to a previous state.

After opening the registry with regedit.exe, use the search function to find any instances of "Nero" or "Ahead". If you've already uninstalled Nero, you can safely delete these entries in the registry. Wherever you find an entry, highlight the root entry and use the "delete" key to delete the entire subsection.

Once you're done, close the registry and reboot. You should be ok then.

Hope this helps.


Many thanks for your help again. I ditched Nero, bought Easy CD Creator, installed it and all seemed to work OK. Maybe I'm unlucky (or incompetent!), but since installing EZCD, my CDR (TEAC CD-W 512EB) will write to a CD, but often, my DVD (Pioneer DVD-ROM DVD 116) can't read it. When I put the same 'just written' CD back into the CDR, it says it doesn't recognise it!! This doesn't happen all the time - just sometimes - but enough to get me really fed up. Never mind - I've got some cheap CDR's to waste. How do software companies get away with it?:mad:
I don't expect a response - but any more suggestions would be much appreciated.
Have you installed all the updates to EZCD? There is now a 5.02d patch ...

that you can download for free on the roxio website. Also, make sure you DO NOT install Take Two. That will mess up your system. If it's installed, the 5.02d patch will disable it. There is a known incompatibility with WinXP.

Additionally, if you have DMA enabled for your drives in your bios, disable it. Sometimes that causes problems. Make sure the bios is set for CDROM on the channels that the CD devices are assigned to.

Make sure you disable WinXP's native burning feature. That will sometimes cause a problem.

I'm assuming you have the master/slave settings right on your CD devices. Any CD should be on your 2nd IDE connector, not the first. Let the HDD's have that one to themselves.

On your CD's, make sure you select "Close session" when you record. A standard CD reader can't read an "Open Session" CD without special software.

Without more information on your setup, it's difficult to troubleshoot the problem. Hope all this helps.

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
What a long strange trip it's been. =)

Forum statistics

Latest member