cd rom - dma

P

PHiSHnz

Guest
#1
hey
after having a few probs and reinstalling OS a few times, playing around..
i was looking through device manager and under the secondary IDE channel option.. it says my primary CD Rom is only using PIO while the CDRW is using multi-word DMA mode 2
i'm sure the primary 50X cdrom used to use that too.. and i'm sure it used to run faster.
any idea why ? or how to fix it?

greatly appreciated.. thanks
 
M

Master-J

Guest
#2
check to make sure that that the ide channel is set to use DMA if available and make sure that the settings are correct in bios.

if the problem remains, pull out the IDE cable from ur mobo that the cd drive is on and switch it around to the other slot (ie primary to secondary). this worked for me, since the mobo got it into its head that the drive couldnt use dma, so switching it to another slot made it reinitialise the drive and pick up dma.

btw, each cdrom was on a separate cable, with its own slot, so i didnt have to move around any hdd's
 

JJB6486

Retired Mod
Political User
#3
First check the BIOS. It should be set to DMA or Autodetect.

Then check Windows. Open the system control panel, then the Device Manager from the hardware tab. Open the properties for the ATA/ATAPI controllers and select either the Primary or Secondary channel (depending which one the drive is on), and go to the advanced tab. Make sure "Use DMA If Possible" is selected from the menu under the correct Master or Slave position.

If its still PIO, then its all your drive supports. My CD-RW only works in PIO 4, where my DVD-ROM is Multi-Word DMA Mode 2

JJB
 
J

jcs83md

Guest
#4
I had a similar problem. In the end, it turns out the BIOS setting for the CD-Rom had it at ULTRA DMA Mode 2, I set the Ultra DMA to disabled for the CD-RW, and the next time Windows started it changed from PIO 4, to DMA 2.
 

BonyTony

OSNN Senior Addict
#6
Try using search you would have found my early solution m8ty

Open REGEDIT and find the following keys:

HKEY_LOCAL_MACHINE\SYSTEM\curr
entcontrolset\control\class\ {4D36E96A-E325-11CE-BFC1-08002BE10318}\000x

Last four digits are likely 0001, 0002. Under those keys you will find MasterIDdataChecksum, SlaveIddataChecksum. Delete the value corrosponding to your drive by right clicking on the master and slave checksums and then choose modify and delete the value data box contents do this to both 0001 and 0002 lines.
 

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,969
Messages
673,295
Members
89,015
Latest member
arrangel