• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Broken Sherlock.app

SPeedY_B

I may actually be insane.
#1
Ok, my copy of sherlock is screwed, right in the head. :dead:

When I open it, it's fine, it can sit there for hours on end doing nothing, but as soon as I attempt to click on a channel it dies and gives me the usual "send error report to apple" rubbish. Things that I've tried so far:
  1. Deleting the .plist file to start again
  2. Deleted the application cache
  3. Copied over sherlock.app from my iBook (it works on there, not on here)
  4. Re-installed sherlock from my 10.3 CD from /System/Installation/Packages/Essentials.pkg using pacifist
but it still does not work. I even deleted the damned thing then re-installed fresh, but still no luck. If anyone can help me with this it'll be greatly appreciated, I use Sherlock quite a lot and am pissed off there seems to be no solution to this problem.


Screenshots of what happens:

cfb
 

SPeedY_B

I may actually be insane.
#3
Yup, tried all that.

I'm now thinking that it may be down to the webkit framework that I once updated when I installed Safari 1.3, as I reverted back to Safari 1.2.x, but never restored the other files I updated at the time. Bugger.
 

jimi_81

Moderator
Political User
#4
i used a mac during the summer, i remember there being a problem with a preference file... deleting the preference file and reinstalling on bootup..

that isnt much help... i tried googling it ... obviously u did..
macfixit.com said something about purchasing a subscription to view the article... "Sherlock issues related to corrupt preference file"
 

SPeedY_B

I may actually be insane.
#5
As I said in the first point in my post, I deleted the .plist file, it's the first thing to try when something goes wrong.
 

SPeedY_B

I may actually be insane.
#7
Yeah, usual pratice would be:
Check file permissions, fix as necessary.
Delete app cache if applicable.
Delete any preference files.
Resort to the internet. :p

I've tried all that and much more and the damned thing still doesn't work :D
 

X-Istence

*
Political User
#8
Geffy said:
tried the usual of repairing permissions and running fsck -fy and so on
fsck -fy is run on startup of Mac OS X, everytime. If anything is wrong with the file system, it is journaled and anything done can be rolled back, and be recommited to the HD.

Ah, the power of journalled.

SPeedY_B:

Hit submit report, then down in the box it says exactly what went wrong, paste that here. Then i can see in what library it went wrong, and advise you.

If you did update webkit, downgrade it. And see if it works then.
 

X-Istence

*
Political User
#10
Thread 9 Crashed:
0 com.apple.CoreFoundation 0x90194fc4 __CFStringCreateImmutableFunnel3 + 0x450
1 com.apple.CoreFoundation 0x901adf48 CFStringCreateWithCharacters + 0x3c
2 com.apple.JavaScriptGlue 0x84bc9728 UserObjectImp::get(KJS::ExecState*, KJS::Identifier const&) const + 0x5c
3 com.apple.JavaScriptCore 0x96f19128 KJS::Reference::getValue(KJS::ExecState*) const + 0x210
4 com.apple.JavaScriptCore 0x96f185b8 KJS::FunctionCallNode::evaluate(KJS::ExecState*) + 0x23c
5 com.apple.JavaScriptCore 0x96f1cd58 KJS::ExprStatementNode::execute(KJS::ExecState*) + 0x94
6 com.apple.JavaScriptCore 0x96f1ae80 KJS::SourceElementsNode::execute(KJS::ExecState*) + 0x17c
7 com.apple.JavaScriptCore 0x96f28ac4 KJS::BlockNode::execute(KJS::ExecState*) + 0xd0
8 com.apple.JavaScriptCore 0x96f1fb50 KJS::InterpreterImp::evaluate(KJS::UString const&, KJS::Value const&) + 0x6f8
9 com.apple.JavaScriptCore 0x96f2f998 KJS::Interpreter::evaluate(KJS::UString const&, KJS::Value const&, KJS::UString const&) + 0x2c
10 com.apple.JavaScriptGlue 0x84bcaa7c JSRun::Evaluate() + 0x44
11 com.apple.JavaScriptGlue 0x84bca0c0 JSRunEvaluate + 0x28
12 com.apple.SearchEngine 0x85899d28 JSRunEvaluate + 0x54
13 com.apple.SearchEngine 0x85898774 JSGlueRunEvaluate + 0x34
14 com.apple.SearchEngine 0x85899cc0 SEJSRunEvaluate + 0x2c
15 com.apple.sherlock.core 0x81c9d514 -[SherlockChannelInstance _initializeJavaScriptEntry:] + 0xb0
16 com.apple.Foundation 0x90a39b74 forkThreadForFunction + 0x6c
17 libSystem.B.dylib 0x900246e8 _pthread_body + 0x28


Looks like it does not like your javascript stuff.

Downgrade by replacing the proper stuff in /System/Framework/ i think it is. Use md5 and the files on your iBook to compare.

Then copy over the ones from your iBook, which do not match as you are certain your iBook works.
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,013
Latest member
Pdawgintown