how do you set up an ftp server?

Discussion in 'Windows Desktop Systems' started by koko, Jul 8, 2002.

  1. koko

    koko Got Root?

    Messages:
    577
    Location:
    Columbia, S.C.
    i need some help from you guys.

    i'm attempting to set up an ftp server on my winxp system. i have installed serv-u ftp proggy on my system. i have configured it and even set up user accounts.

    i also have a linksys router...i opened the port that i plan to run the ftp server on and can connect to the server through my browser at home.

    but, the users outside my home can't connect to me.

    i'll admit i'm a noob at this ftp stuff! just wondering what i need to do to get this baby up and running.

    does the prob lie with my router's ip or something?

    suggestions?
     
  2. koko

    koko Got Root?

    Messages:
    577
    Location:
    Columbia, S.C.
    anyone? :(
     
  3. MaDCeLL

    MaDCeLL Guest

    are you sure that you have enabled portfowarding (21) to your computers intranet ip on your router ?
     
  4. PseudoKiller

    PseudoKiller Zug Zug

    Messages:
    3,858
    Location:
    Ice Crown Citadel
    Hmm I have the almost exact setup you have. Linksys > Serv-U Ftp Server but on a Win2k pro machine.
    If users cannot connect to you do they have the correct IP?? And is your IP static or dynamic. Do you have the port 21 correctly set to forward to the correct machine that is serving the Serv-U ??

    PS do the users that try to connect to you, do they get any kind of error when trying to connect??
     
  5. MaDCeLL

    MaDCeLL Guest

    user that want to connect to a ftpserv that is behind a fwall should try using PORT instead od PASV !
     
  6. JJB6486

    JJB6486 Retired Mod Political User

    Messages:
    1,207
    Location:
    West Lafayette, IN, USA
    Or if you want to use PASV, set a PASV port range, and set the PASV IP to your EXTERNAL internet IP, and forward both port 21 (or whatever the connection port is) and the range set for PASV to the internal computer

    JJB6486
     
  7. koko

    koko Got Root?

    Messages:
    577
    Location:
    Columbia, S.C.
    users don't get any error messages, the ftp proggy they use to connect just hangs....or if they're trying to connect via their browser, it just hangs.

    not sure if i've done that...

    i should set port forwarding to my computer's ip and not the router's ip?
     
  8. MaDCeLL

    MaDCeLL Guest

    well users in the internet only see sour router... so you have to forward a specific port to a machine where you would like it to be.

    so if you have ftp on port 21 on your computer... you have to tell your router that it should forward any connect to that port directly to your computer
     
  9. koko

    koko Got Root?

    Messages:
    577
    Location:
    Columbia, S.C.
    i'll give that a try....thnx for the advice. ;)
     
  10. koko

    koko Got Root?

    Messages:
    577
    Location:
    Columbia, S.C.
    :(

    didn't work. i set the port number in my router interface to go to my 'puters ip addy. it's still not working.

    any suggestions on a direction to take from here? :confused:

    signed,

    -lost in ftp land
     
  11. rnielsen151

    rnielsen151 OSNN Junior Addict

    Messages:
    39
    The ony way i could get mine to work is to set the dmz to the ip address of the machine with the ftp server software running....
     
  12. koko

    koko Got Root?

    Messages:
    577
    Location:
    Columbia, S.C.
    haven't tried that yet. thnx! ;)
     
  13. Geo

    Geo Guest

    I have serv-u running on an xp box and with the linksys router. on the routeer set 20 through 21 to be forwarded to the ftp inside IP. on serv-u setup a domain and a user account. ie john. grant him access to a FOLDER on the ftp server which has a FILE in it. and have someone login as john and a password and see if that person can see the FILE. the home directory should be a FOLDER on the ftp serv. also check the log file on the server to see if they are even connecting if they aren't then your ISP is blocking 20-21
     
  14. koko

    koko Got Root?

    Messages:
    577
    Location:
    Columbia, S.C.
    thnx for the help.

    i've have tried everything you suggested, including opening ports 20 and 21. that didn't work, so i switched to another port (253).

    in addition, i went into linksys router interface and changed dmz host to be my computer's ip addy (as suggested by someone else).

    i have an account w/ password set up for a friend. he tried logging on tonight (via ftp commander) and couldn't get in. he said it just sat there and never connected.

    this is truly frustrating.

    any other suggestions?

    -lost forever in ftp land! :(
     
  15. rnielsen151

    rnielsen151 OSNN Junior Addict

    Messages:
    39
    set your computer with the ftp to have static address


    SETUP TAB
    --------
    ip 192.168.1.110 <-----ftp machine
    subnet 255.255.255.0
    gateway 192.168.1.1 <--------- internal address of router


    FORWARDING TAB
    -----------------------
    service port range 20 ~ 21 Both 192.168.1.110 <-------ftp machine ip

    DMZ Host
    -------------
    192.168.1.110





    in serv-u 4 under settings tab

    check ALLOW PASSIVE MODE TRANSFERS, USE IP XXX.XXX.XXX.XXX <-------YOUR EXTERNAL IP ADDRESS
     
  16. rnielsen151

    rnielsen151 OSNN Junior Addict

    Messages:
    39
    that first set is not the setup up tab...its the settings on your machine....sorry
     
  17. Geo

    Geo Guest

    Lets not forget that DMZ leaves you wide open.
     
  18. koko

    koko Got Root?

    Messages:
    577
    Location:
    Columbia, S.C.
    thnx for the advice rnielsen151. i truly appreciate it.

    i'll try this setup as soon as i get home.

    hope this works! :)


    yeah geo, i was kinda worried about that dmz thing. leaves me swinging in the breeze......wide open for hackers.
     
  19. Terrahertz

    Terrahertz Extinction Agenda Political User Folding Team

    Messages:
    972
    Location:
    New York
    Hi Koko. Hmm an FTP plight. Well first of all you should not have to enable DMZ. I also lave a linksys router and run ftp with a cable modem. Im not sure what broadband conn your using but you need to check your settings over and try to pinpoint where your problem lies. It has been said before but lets go over it one more time.
    Make sure SPI is disabled on filters screen
    enable port 21 to your computers private ip
    enable ports 50000>50100 to your computers private ip

    Go to your serv-u software and put in your WAN ip where it belongs.{Allow passive mode data transfers should be checked}
    In the PASV port range put 50000>50100
     
  20. koko

    koko Got Root?

    Messages:
    577
    Location:
    Columbia, S.C.
    thnx th,

    i'll give that a shot when i get oughta hell......i mean work.