Connecting to my FTP problem - Part2

Discussion in 'Windows Desktop Systems' started by Heeter, Sep 17, 2004.

  1. Heeter

    Heeter Overclocked Like A Mother

    Messages:
    2,732
    Hi Guys,

    Well, after finding out that port21 is not available to my FTP server (ISP), I have been trying several other ports. I seem to have encountered a new problem. Whenever a family member tries to logon, their username/password comes through, then an error shows up on their FTPClient.

    COMMAND:> LIST

    150 Opening data connection for directory list.

    425 Cannot open data connection (10060).

    This error comes up at the bottom. These errors have been coming up since I switched away from port 21. Does the FTP Server only recognize port21?

    I am testing with port340 for now. I forwarded ports 339 to 341 on my Linksys router, and chose port 340 as my default port in my Bulletproof Server proggy. Can someone tell me what this error means?

    Thansk in advance.

    Heeter
     
  2. Mainframeguy

    Mainframeguy Debiant by way of Ubuntu Folding Team

    Messages:
    3,763
    Location:
    London, UK
    I would GUESS that is exactly it. But cannot confirm because I have yet to build the rig that is going to liberate this one to be my ftp server. Someone else will though - I am just backing your hunch for now....
     
  3. Johnny

    Johnny .. Commodore .. Political User

    Messages:
    5,015
    Location:
    Happy Valley
    With a router you have to enable dmz to use any port but 21. doing this is not good unless the you have a "dedicated server" with a software firewall ..

    Here is a site that will help as far as port 21. I know it is useless in your situation. But it gives the basic idea ..

    http://www.linksysftp.org/bpftp.php
     
  4. Heeter

    Heeter Overclocked Like A Mother

    Messages:
    2,732
    Thanks Johnny,

    I remeber you mentioning this exact situation on the other FTP problem thread that I was having.

    What about the "passive mode" feature available with Bulletproof. I don't have it checked off as being used. Can I use it to my advantage in this situation?



    I will try DMZ.

    Heeter
     
  5. Mainframeguy

    Mainframeguy Debiant by way of Ubuntu Folding Team

    Messages:
    3,763
    Location:
    London, UK
    so my hunch was half right?
     
  6. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    Thats not true, you can forward any port, not just port 21. you have to specify a different port when connecting though, because most FTP client software will assume port 21.
     
  7. Heeter

    Heeter Overclocked Like A Mother

    Messages:
    2,732
    j79lzr,

    That is what I did. The client does logon, the problem lies when the client is logged on (In this case, port340), it does not see any of the file listings in the FTP Server. Reading through that site, I think that the problem lies with the fact that my Linksys BEFSR41 is freaking out that I am using a non-standard FTP port. I am still trying to figure out how to get the listings to show up on the client.

    Mainframeguy, your hunch is half correct, it is the router, not the Server proggy that is the fault so far.

    My FTP tower is a standalone, it can be DMZ enabled if need be. I still would like to figure out how to stay behind the router though. I have never used the passive settings in Bulletproof, would now be a good time to if it can be used to my advantage?

    Heeter
     
  8. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    That sounds like the PASV mode problem, did you also forward the range of passive ports to the servers address?
     
  9. Heeter

    Heeter Overclocked Like A Mother

    Messages:
    2,732
    j79zlr,

    Would you be able to show how to do that? I think that is where my problem lies. Before my ISP locked up my port21, all the clients using my server had to check off the PASV setting on the client. But, the router never had a situation using that port in the last three years or so. I am kind of scrambling right now, trying to figure out if it really is the PASV settings.

    That would be much appreciated.

    Thanks in advance.

    PS: Johnny, that site was a great find, Thanks.

    Heeter
     
  10. Johnny

    Johnny .. Commodore .. Political User

    Messages:
    5,015
    Location:
    Happy Valley
    That is not a passive mode problem. It is a router problem .. Removing the router and hooking the pc directly up to the connection it will work perfect. With the router it is restricted. In order for it to work with a router you have to have dmz enabled. In some cases it will work with passive mode, but like he is experinces, you will get lagging - failed connections - no listing of directories ...

    What you could also do is this. Set it to a higher port, then when you log in you have to put in you are setting behind a nat firewall. There should be a check for it in the options folder of the site manager when you set the site up. That might work ..
     
  11. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    I disagree, this sounds very much like a classic PASV mode problem. DMZ is not needed, and not recommended. FTP works with routers unless they are broken.

    Heeter: As I told you in the other thread (and as I think Johnny is suggesting), you should choose a port above 1024. 340 might work, but for good measure, pick one above 1024 (I usually take 2100 or 2121, easy to remember). And there's no reason to forward the ports around (like 339 and 341). Also you'll need to forward a PASV range.

    So:
    1. Set and forward the main port (2100 or whatever)
    2. Forward PASV range (high ports suggested, 65100 - 65199 or so for 100 ports)
    3. Set PASV range in server, there should be a setting for it.

    That should do it.

    The reason it may have worked before without a PASV range is that some routers are aware of the problems with FTP and allow incoming connections from computers that allready have an open session on port 21. Some routers even have the "Non standard FTP port" setting which, at least in theory, should let you specify the port you're using for FTP (2100 or whatever) and skip the PASV setting. I've never tried this though.
     
  12. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    Right Zedric, the only reason why putting a PC in the DMZ would fix this problem is that you are not forwarding the correct ports to it with the router, and bypassing the security of the NAT of the router.

    ftp://j79zlr.homeunix.com
    user:ftp
    pw: not required

    that is an ftp server behind a NAT router with passive mode enabled.
     
  13. Heeter

    Heeter Overclocked Like A Mother

    Messages:
    2,732
    Hi Guys,

    Thanks for the help so far. What kind of settings would the client proggy need? PASV checked off, how about the NAT checkmark? My router is working fine, but, should I look for a firmware upgrade? Linksys BEFSR41 is the model I have. 1.45.7 is the current firmware. Would upgrading to the latest one help? Client is still hanging up on showing files, but is logging in. Client is a freeware version of CuteFTP5

    Thanks in advance,

    Heeter

    Thanks in advance.
     
  14. Geffy

    Geffy Moderator Folding Team

    Messages:
    7,805
    Location:
    United Kingdom
    tried connecting in PORT mode (PASV Disabled) on the client?
     
  15. American Zombie

    American Zombie Moderator Staff Member Political User

    Messages:
    2,931
    Location:
    Seattle
    :eek: :confused: :eek:
     
  16. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    Always upgrade to the latest firmware
     
  17. Johnny

    Johnny .. Commodore .. Political User

    Messages:
    5,015
    Location:
    Happy Valley
    You are using port 21 on that, using port 21 will work. He wants to use a diff port ... Try to set it up that way and lets see if it works :)
     
  18. Tuffgong4

    Tuffgong4 The Donger Need Food!!!! Political User

    Messages:
    2,465
    Location:
    Chicago
    I also have a befsr41 ver.1 that I have stopped using because there have actually been tons and tons of problems with linksys' new firmware for the past like 5 updates...it could be a firmware problem ...

    do a google about befsr41 ver1 or ver2 and firmware and you will see the tons of posts about how people are having problems...not sure if they relate to your problem but you will see if it does...

    btw here is the update for your router if it is ver1 or ver2
    http://www.linksys.com/download/firmware.asp?fwid=3

    edit... in case it's ver3 or higher
    http://www.linksys.com/download/firmware.asp?fwid=183
     
  19. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    It doesn't matter what the port is, you just have to then add the port to the url, e.g.

    some.ftp.site.com:4000

    and of course you have to configure the ftp server correctly.
     
  20. Johnny

    Johnny .. Commodore .. Political User

    Messages:
    5,015
    Location:
    Happy Valley
    That is true j79zlr. I just read a lot of sites about port forwarding they all said that when you setup the server you have to use the main defualt port and -1, It is this way if you also use another port other the default ( I guess routers see port 21 as the default) and also open the passive range.

    Other wards if you want to use 300 you have to also open 299 in your router. 300 for the transfer and 299 for the connection. And if you want to use 50000 50050 for the passive range you have to also open that. You also have to add your outgoing ip to the ip binding. I was not opening the -1 so this could be the prob I was having. I have not tried this yet myself, so I can't comment if it works or not.