XP Tcpip related problem

Discussion in 'Windows Desktop Systems' started by warrenliang, Mar 22, 2002.

  1. warrenliang

    warrenliang Guest

    Hi,

    My XP (Professional version) TCPIP does not function too well.It can not access Internet. In addition, while enter 'telnet anynode' command, following error message shows up:
    connection to anynode... Could not open connection to the host on port 23.
    WSAStartup can not function at this time because the underlying system
    it uses to provide network services is currently unavailable.


    Regardless of tcpip's configuration, either DHCP client or static ip, the identical problem occurs. While defined as a DHCP client, it gets ip address assigned from server. I am able to ping to Inter/Intra node; nslookup works also.

    Microsoft Netowk works fine.

    Thanks in advance.
    Have a good weekend.
    Warren
     
  2. Qumahlin

    Qumahlin Moderator

    Messages:
    2,006
    have you tried re-installing the TCP/IP protocol for the selected connection? and how are you trying to connect to your provider? do they use DHCP or static?
     
  3. warrenliang

    warrenliang Guest

    I tried to reinstall Tcpip protocol. However, when I click 'Tcpip Protocol' from Control Panel-Network, the 'uninstall' become dim, can not proceed to re-install it.
    I have a Linksys Router as the DHCP server and default gateway. The XP gets ip address assigned from the Linksys. During the trouble shooting, I connected the XP directly to cox.net (my cable modem ISP), XP received ip address directly from cox.net. The ipconfig /all shows all required addresses. However, I still could not access to Internet nor issue telnet and ftp.

    Thanks for your information.