Xp SP1 and Media Player

Discussion in 'Windows Desktop Systems' started by looopy, Sep 10, 2002.

  1. looopy

    looopy Guest

    After successfully installed SP1, whenever I try to open a file (either mp3, avi or whatever) under Media Player, I get an error message. The same error stays after I upgraded it 9 beta

    The following is the error signature.

    AppName: wmplayer.exe AppVer: ModName: mmswitch.ax
    ModVer: Offset: 00004e86

    Any advice?
  2. gilerzz

    gilerzz Guest

    You can try removing WMP from add/remove programs and reinstalled the Beta 9 WMP, see if it helps.
  3. looopy

    looopy Guest

    The real problem is that I encounter the same error with Real player:

    AppName: realplay.exe AppVer: ModName: mmswitch.ax
    ModVer: Offset: 00004e86

    Both error msgs have mmswitch.ax, I guess that's the source of error, how should I fix it?

    Edit: I think it's a problem related to Nimo code build 8
  4. yoyo

    yoyo _________________

    mmswitch.ax seems to be a DirectShow filter that interferes with several players. You can get rid of it by: START< RUN type: regsvr32 /u C:\...\...\mmswitch.ax (Insert the path for...\...) Information gained only by a quick Google search, so no guarantee. You can undo the action by repeating it without the /u .
  5. looopy

    looopy Guest

    I uninstalled Nimo 8 and installed Nimo 7, unchecked some stuff that my system doesn't need, now everything's fine.
  6. djmorgan

    djmorgan OSNN Addict

    I think this has the making of a bigger bug, after SP1 my WinDVR2 stop working with the same error message, I'll try the Nimo fix now, athough have tried the build 8 and lite pack with no result. :mad:
  7. rlatchana

    rlatchana Guest

    i heard rumors that xp service pack 1 restricts use of mp3 files. I have been unable to find details on the internet. Does anyone know about this?
  8. Nah, thats just a rumour, i have been using SP1 with no problems, and i have some 2000 mp3's!:cool:

    SP1 has been emitting small bugs on my system though, it for some reason disables the SOUND icon on the system tray, so now i have to keep gonig into Control panel to adjust sound!!:confused: