XP DUN and LAN via Router problems

Discussion in 'Windows Desktop Systems' started by Kane, Mar 16, 2005.

  1. Kane

    Kane OSNN One Post Wonder

    Messages:
    4
    Hi

    My first post here, sorry it's a request for help, but I hope I can help others out too

    Anyway, I'm having MAJOR problems getting a networking system running:

    Current system is:

    1) PC connected via ADSL modem to the Internet
    2) Same PC connected via 10/100 Ethernet to a router
    3) 3-4 other machines connected to same route

    Now, I want the other machines to access this machines internet connection.

    However, as soon as I run the network wizard and pick "machine connects directly to net, other machines share this connection" (or something like that), the internet machine can no longer see the rest of the network and vice-versa!!

    This is really doing my head in. I know I could connect all the machines to the router (it does have ADSL), but a piece of sotware I'm using (dialip access to video cameras) will only work if the main machine is connected directly to the net via the ADSL modem.

    Anyway help here would be GREATLY appreciated. I don't have massive experience of multiple networking, so a step-by-step answer would be great.

    Thanks in advace
     
  2. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    Well, the problem here is what you need isn't a router, it's a switch or hub. Now, since the router probably allready contains a switch, that's ok, you can use it instead of buying a switch if you wish. There are however a few things you need to do:

    1. Turn off DHCP in the router. It can't be allowed to give out IP addresses to the other computers.
    2. Make sure the IP of the router isn't 192.168.0.1 on the LAN side. This is because that IP will be the IP of the ADSL connected computer once you set up the Internet sharing. I suggest you give it 192.168.0.250 or something so that you can still reach it.
    3. Make sure the other computers are set to use automatic IP (this is default).
    4. Now enable Internet Connection Sharing on the ADSL modem on the ADSL connected computer. This will set the IP of your other network card to 192.168.0.1 and make the computer hand out IPs to the other computers. Also make sure the firewall is turned on on the ADSL interface since you aren't connecting through the router anymore.

    This should be about it. If file sharing worked before, it should work just as well afterwards.


    The ideal would af course be to have the modem connect to the router and set things up the normal way, but if your software refuses to work, then that's it I suppose. Unless it isn't just a matter of port forwarding?

    [EDIT] Oh btw, skip the guides and stuff, they're not very good anyway. ;)
     
  3. Kane

    Kane OSNN One Post Wonder

    Messages:
    4
    Zedric, thanks VERY much for you help. I hope you don't mind me asking a few more questions:

    > Well, the problem here is what you need isn't a router, it's a switch or hub. Now, since the router probably allready contains a switch, that's ok, you can use it instead of buying a switch if you wish.

    If I got a router/switch/hub (what's exactly the difference) without ADSL on it, would it just work without any other configuration?

    > 1. Turn off DHCP in the router. It can't be allowed to give out IP addresses to the other computers.

    How would I do this? It's a trust model, but I don't know a lot else.


    > 2. Make sure the IP of the router isn't 192.168.0.1 on the LAN side. This is because that IP will be the IP of the ADSL connected computer once you set up the Internet sharing. I suggest you give it 192.168.0.250 or something so that you can still reach it.Again, do I do this from the router, or within Windows??
    4. Now enable Internet Connection Sharing on the ADSL modem on the ADSL connected computer. This will set the IP of your other network card to 192.168.0.1 and make the computer hand out IPs to the other computers. Also make sure the firewall is turned on on the ADSL interface since you aren't connecting through the router anymore.



    > The ideal would af course be to have the modem connect to the router and set things up the normal way, but if your software refuses to work, then that's it I suppose. Unless it isn't just a matter of port forwarding?

    Well maybe it is. Basically, the remote program let's you monitor the cameras from a dialip connection, you just input the IP address.

    Unfortunately, there's no documentation available (I've triied the manufacture but they didn't answer) on how this program communicates with the server handling the cameras. Would you have any ideas on how to find this out?

    Is port forwarding a router feature, or does Windows handle this?

    Again, thanks
     
  4. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    If you connect the ADSL modem to the WAN port of the router ("the outside") and the computers to the LAN ports ("the inside") it should work with no or minimal setup. It depends on if you have static IP, PPPoE with login and so on. (This has to be setup on the PC normally if you connect directly like you do now.)

    In short, the important differences between switches, hubs and routers is that switches and hubs simply connects computers on the same network. A router connects computers between networks (like between your network and the Internet). In the instructions I gave above we disable the router's functions and just using the switch part of it.

    The settings of the router are done in the router, but is normally done from one of your computers. There are generally two major ways of doing this, depending on brand and model (I here assume the IP of the router is 192.168.0.1, it may not be the case allways):

    1. Open a web browser and type in 192.168.0.1. You will be taken to a page where you can configure the router. Normally there is a login and password required.
    2. Click Start > Run. Enter telnet 192.168.0.1 and press enter. You will get a text menu where you can configure the router. It's likely this will require a login as well.

    How your particular router can be configured and what the login may be should be found in the manual.

    Do you have any links to this software/hardware? Are you monitoring cameras outside your network (which should work right away)? Or are they on the inside (which is harder)?

    Port forwarding is a router feature.
     
  5. Kane

    Kane OSNN One Post Wonder

    Messages:
    4
    Thanks again

    > f you connect the ADSL modem to the WAN port of the router ("the outside") and the computers to the LAN ports ("the inside") it should work with no or minimal setup. It depends on if you have static IP, PPPoE with login and so on. (This has to be setup on the PC normally if you connect directly like you do now.)

    It's a static IP, PPoA with login connection. The ADSL modem is USB, so I couldn't connect it via the router anyway, although as I say the router has a built in ADSL modem (the WAN socket connect to the phone line).


    > Do you have any links to this software/hardware? Are you monitoring cameras outside your network (which should work right away)? Or are they on the inside (which is harder)?

    Well baisically, the camers (8 of them) are connected to 2 PCI cards into the main machine. This then runs monitoring software to view the cameras. You can run the remote software either via LAN (you can browse to the machine) or by typing in the IP (for when you'd use dialip).

    I've just got no way of knowing exactly HOW this dialup software communicates with the main program. Is just having the net permanently connected to this machine and the others sharing (as you explained how I could do it) a bad idea? I'd definately prefer everything (including net access) via the router, but I just don't know how I'd configure everything so that the remote machine can login via the company's static ip.
     
  6. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    Ah, now I see, thank you. I missread you a bit before.

    This is then a port forwarding issue. The fact that the remote access works now means that the Windows firewall on the main machine has been turned off, right? This is, if that is the case, a really bad idea. It means that the main computer has no protection towards the outside world. Especially since this is a corporate network, this is a big no-no.

    So what I suggest you do is this:

    1. Find out what port(s) the dialip (dialup?) software uses to connect to the camera server (i.e. main machine right?).
    2. Reconnect the network so that the router is connected to the Internet and everything else off the router.
    3. Forward the port(s) to the main machine. Hopefully (and chances are good) this will work.

    So how do we find out what port(s) are used? Well, there are two ways I can think of:
    1. Check the manual or call the manufacturer. It seems you did this, but got no reply.
    2. Sniff it out. This isn't trivial, but hopefully it'll work.
    * Click Start > Run and type in cmd.
    * At the prompt run cd C:\ (or whatever folder you want to store the coming text file in).
    * Run netstat -abn > ports.txt. This will create a file called ports.txt containing information on the connected port and listening ports on the main computer. The ports listed as "LISTENING" that are connected to the application of the camera server should be the ones we're looking for. Paste the contents here if you want help reading them. Please use the [ CODE ] tags when you do. ;)

    I forgot to say Welcome to the Forums! Now, there I've said it. ;)
     
  7. Kane

    Kane OSNN One Post Wonder

    Messages:
    4
    Thanks again Zed :)

    I tried what you suggested, found the port (1999) and found some info on the router and how to do forwarding.

    It's all working great now, thanks very much for the help.

    Cheers :)
     
  8. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    Wonderful! :)
     
    Kane likes this.