windows management instrumentation causing sp1 to not install??

Discussion in 'Windows Desktop Systems' started by bystander, Sep 10, 2002.

  1. bystander

    bystander Guest

    hi there guys.
    i think i have not been able to install sp1 because my windows management instrumentation software isnt working, dont know why it isnt because everything its on but when i load system information it says that it cannot access the windows management instrumentation software. Windows Managemente files may be moved or missing.
    and i think i cannot install sp1 because of this, it needs this one to be ok to check the key, right?
    sure hope someone could help with this one without having to reinstall xp
    thanks so much guys
     
  2. dadx2mj

    dadx2mj Guest

    Have you tried running system file checker? Just go to a run dialog box and type "sfc /scannow" without the quotes and make sure you have a space between sfc and the /. You will also need your XP install disk in the CD drive. Good Luck
     
  3. bystander

    bystander Guest

    thanks for replyin so fast, but unfortunetaly i had already tried that and it didnt work out :(
     
  4. eNuffSaid

    eNuffSaid Guest

    Is the WMI service started?

    Start > Run > services.msc > Windows Management Instrumentation ...
    Is it started? Its startup type should be Automatic

    Can you connect to your WMI?

    Start > Run > wmimgmt.msc > Right Click WMI Control (local) > Properties...
    It will connect to your WMI.

    Have you checked your WMI Logfiles @ C:\WINDOWS\system32\WBEM\Logs\ You can set you logging settings from the properties of WMI Control (local).

    Kind regards,
    Willem Moolenaar
     
  5. bystander

    bystander Guest

    yep enufsaid
    i can do all that, although i didnt knew that one about wmimgmt.msc, it connects me to wmi
    but i think that you probably hit the bullseye, when you talk about the wmi control (local) properties, when i choose that it appears on the screen

    failed to initalize all required wmi classes

    Win32_Processor: Interface: class not registered
    Win32_WMISetting: Successful
    Security Information: Successful
    Win32_OperatingSystem: Interface: Class not registered


    i hope you understand something about this, because i sure dont
    and i hope something can be done without havin to reinstall :)

    thanks so much
     
  6. eNuffSaid

    eNuffSaid Guest

  7. bystander

    bystander Guest

    thanks so much again willem
    for the wonderful insight
    after i installed the patch
    all remained the same :(
    but on the event viewer
    wmi started giving this error

    Failed to load MOF C:\WINDOWS\System32\wbem\iiswmi.mof while recovering repository file.

    any clue about this?


    and you mentioned repair / reinstall
    youre talking about the same thing
    or is it really possible to do a repair on xp withou having to reinstall to all deal?

    cant thank you enough :)
     
  8. eNuffSaid

    eNuffSaid Guest

    Hi Bystander,

    I'm sorry to say I'm having a hard time with your problem. I know there is a M$ download called "wmicore.exe." Its a 6+ MB download, but I can't seem to find it at M$.

    Have you tried the following M$ article:

    INFO: Tips on WMI Driver Testing

    http://support.microsoft.com/default.aspx?scid=KB;EN-US;Q252679&

    If that doesn't work, I'm afraid you'll have to do a "repair" installation. If you boot your WinXP CD, a "repair" should be one of the options you will be provided with.

    Kind regards and good luck with you troubles,
    Willem Moolenaar
     
  9. bystander

    bystander Guest

    i dont know what to tell you willem, i think i solved the problem by installing wmi snmdp or something (sorry cant remember righty now :)
    that i saw that i didnt had installed on the add/remove programas, windows component sections :)
    all i know is that it went to get some files on the xp cd, and dont know why, sp1 installed :)
    who will ever understand m$ right? ;)
    again willem, thanks so much for your patience, youre an all right guy :)
    hope to talk to you in the future
    stay safe in the meantime ;)
     
  10. eNuffSaid

    eNuffSaid Guest

    Hi Bystander,

    Glad to see you got it all worked out. I was struggeling with this one too, mate. Thanks for your kind words. :)

    Kind regards,
    Willem Moolenaar
     
  11. eNuffSaid

    eNuffSaid Guest

    Hi,

    Just wanted to update this thread with the following...

    If you edit your sysoc.inf (system optional components, in your windows/inf folder) you will find an entry in there refering to WMI:

    WBEM=ocgen.dll,OcEntry,wbemoc.inf,HIDE,7

    Remove the "HIDE" word from that line, go to add/remove programs > windows components, and you will see an entry for WMI. Uncheck it, to remove it, and then reinstall it bij checking the box again.

    Kind regards,
    Willem Moolenaar