whats DEVLDR

Discussion in 'Windows Desktop Systems' started by dArK_CyAnIdE, Dec 17, 2001.

  1. dArK_CyAnIdE

    dArK_CyAnIdE Guest

    whats DEVLDR cause that thing crashes pretty often lol... just wondering... thx to ne1 that can help lol
  2. ZipTriX

    ZipTriX Guest

    Do you have a SB Live? If so it has something to do with your sound. well it does on mine.
  3. Speed4Ever

    Speed4Ever Guest

    Its a primary part of the soundblaster live driver, I'm not sure if its in the audigy driver or not, but I cant find it anywhere on my computer except in the i386 driver cache, so I'll say no.

    Its also a primary paiin in the butt for 2K/XP users. Creative has yet to get this one right. As far as I know, theres no real way to fix its problems. Its apparaently hit and miss for most users. Most have problems, some do not.

    Sorry I dont have better news. Let me guess, it crashes occasionally during a game, and almost all the time while shutting down?

    If so, that would be par for the course.
  4. ZipTriX

    ZipTriX Guest

    I think it is just for the SB Live 5.1 (not the audigy). Works fine for me.
  5. Speed4Ever

    Speed4Ever Guest

    It for all the Live cards, as they all work off of modified versions of the same driver package.

    Yes, the Audigy doesnt use DEVLDR (thats one good thing going for it :D )
  6. patchsassy

    patchsassy Guest

    Taken from the DellTalk forum regarding DEVLDR:

    It only happens when you switch users, as you know.

    There seems to be numerous devldr32 files with the same name but different versions on the computer. There is one in the I386 folder, system32 folder and the system32\reinstallbackups\0000 folder. The key is to use the correct version. I think ver is the right one. If you rename devldr32 (ver in the system32 folder, another one will replace it because the service is running. (You have to right click on the taskbar for Task Manager and end devldr service first) then copy the correct version and delete to old one. If you copy and use devldr32 (ver from the I386 folder the problem is gone. I also think that the one in system32\reinstallbackups\0000 folder devldr32 (ver won't work correctly. The one in backups will replace the one in system32. I also had (ver from the latest Creative update (I think). Feel free to verify this solution and comment if I am wrong, but it worked for me. Reboot when done to get the services running again.
    I upgraded the drivers and the versions did not solve it for me. The above solution did.
    If anyone can solve this issue with this solution please let me know,