w3 standards... HELP!

Discussion in 'Web Design & Coding' started by forcer, Jul 28, 2004.

  1. forcer

    forcer OSNN Senior Addict

    Messages:
    413
    after trying to comply with the w3 standards, i'm about to put my computer through a all :angry:

    i just can't eliminate these errors, and that stupid website doesnt offer much help

    http://validator.w3.org/check?uri=h...automatically)&doctype=HTML+4.01+Transitional

    can someone please take a look at that, and offer me any help on why i am getting these errors and how to remove them, thanx :)

    hopefully speedy will take a look at this.. cuz does he f**k answer u on msn :eek: :D
     
  2. Electronic Punk

    Electronic Punk Administrator Staff Member Political User Folding Team

    Messages:
    18,590
    Location:
    Copenhagen, Denmark
    To use <LI> you need to use in like this

    Here is a list
    <ul>
    <li>One</li>
    <li>Two</li>
    </ul>
     
  3. forcer

    forcer OSNN Senior Addict

    Messages:
    413
    if u look on the main nav www.imageoflight.net you can see its indented slightly, this is caused by using

    <ul style=\"margin:0px 0px 0px 15px;padding:0px 0px 0px 0px;\">
    </ul>

    when i add <li>One</li> that adds bullet points, which i dont want. i havent actually been using any <li> tags just the <ul>

    any ideas?
     
  4. Electronic Punk

    Electronic Punk Administrator Staff Member Political User Folding Team

    Messages:
    18,590
    Location:
    Copenhagen, Denmark
    try using blockquote instead of ul
     
  5. Grandmaster

    Grandmaster Electronica Addict Political User Folding Team

    Messages:
    10,574
    Location:
    Santa Clara, CA
    Well it seems to be validating now...
     
  6. Electronic Punk

    Electronic Punk Administrator Staff Member Political User Folding Team

    Messages:
    18,590
    Location:
    Copenhagen, Denmark
    yeah he has put the style on the div instead.
     
  7. forcer

    forcer OSNN Senior Addict

    Messages:
    413
    yes i put the style in the div tag and removed some xml stuff,and it seems ot work fine, thanx guys
     
  8. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    You have valid XHTML on your page, but you are using HTML4 trans. You need to remove all style information and use CSS for it.

    Stuff like this isn't necessary,

    <div style="margin:0px 0px 0px 15px;padding:0px 0px 0px 0px;" class="menubot">

    just use CSS and do not declare the style in the tag.
     
  9. cryogenic

    cryogenic OSNN Addict

    Messages:
    241
    Location:
    TN, blah!
    XHTML 1.1 requires that ALL alignment information be included in css... No target tags either (those are invalidated in XHTML 1.0 strict also). It's good to put all your text formatting into a css file anyway since it makes it so much easier to go back and quickly change things. It also cuts down the size of your html files if you strip them of everything that can be included in a css file. Needless to say, I got mine to validate as 1.0 strict, but can't get it to validate 1.1 because phpgiggle adds blank "rel" tags to all the links it creates. If anyone's php-savvy and could tell me what code in phpgiggle to edit to make it not create the "rel" part of my link tags, I'd be most appreciative.
     
  10. Geffy

    Geffy Moderator Folding Team

    Messages:
    7,805
    Location:
    United Kingdom
    <li style="list-style-type:none">list item</li>

    though a better way is just to have this in your CSS
    li { list-style-type:none; }
     
  11. forcer

    forcer OSNN Senior Addict

    Messages:
    413
    yeah i am going to re-create the css today, but i seem to have trouble with it so it will take me sometime.
     
  12. Geffy

    Geffy Moderator Folding Team

    Messages:
    7,805
    Location:
    United Kingdom
    your site appears to be tentatively valid if you change your doctype definition to XHTML 1.0 Transitional
     
  13. SPeedY_B

    SPeedY_B I may actually be insane.

    Messages:
    15,800
    Location:
    Midlands, England
    Sorry for being away from my screen for 5 minutes :rolleyes:
     
  14. Geffy

    Geffy Moderator Folding Team

    Messages:
    7,805
    Location:
    United Kingdom
    you will be ;)