VIA266A / XP / Drive Corruption

Discussion in 'General Hardware' started by ttocco, Dec 28, 2001.

  1. ttocco

    ttocco Guest

    This is a copy of a post I've made on other forums in the hopes of isolating an issue I've been dealing with for several weeks.
    -------------------------

    Recently I purchased and built a complete system that consisted of the following:

    Epox 8KHA+
    AMD 1800
    256*2 Cruicial sticks (Slot 2 and 3)
    PnY GForce3 ti500
    SB Audigy (Gamer)

    IDE channel 0
    Western Digital 120g 7200rpm (UDMA Mode 5)
    Quantum Fireball 3.2g 7200rpm (UDMA Mode 2)

    IDE channel 1
    Liteon 24X10x40x (UDMA Mode 2)
    Liteon DVD Rom (UDMA Mode 2)

    Windows XP Pro

    My first install with full NTFS format went without a hitch. I used the system happily for a week or so noticing no serious problems until I started examining security rights (disable simple file sharing to access). I found that I had a strange user with a seemingly random name of numbers and digits that had inherited access to parts of my drive. Upon deeper investigation I found that I had a temp file by that same name that simply could not be deleted so I started analyzing my drive.

    Chkdsk has been an odd friend to me here in that no matter how many times I ran it via "chkdsk" "chkdsk C:" or "chkdsk C: /F" it could not repair this problem so I reformatted and performed a clean install. Being highly aware of the previous drive corruption that I assume to be the MFT, I kept dibs on it constantly. The system install and daily use went fine but I started noticing that "chkdsk C:" was reporting errors. I don't know HOW there were errors because this system does not hang, freeze or even hiccup but there they were so chkdsk tells me.

    After several days of me doing this I start noticing more severe errors such as "Page fault in non-paged area" so I reformat again. I begin a low level format but the 10 hour timer makes me pass on this endeavor so I cancel the low level and perform another partition delete, create and NTFS format. I reinstall the system again. As with the first install, I have no problems getting the system running and installing all of the drivers. The system performs fine. After some short period of usage and testing with chkdsk I start noticing the errors AGAIN. At this point I search out a m/b BIOS update from Epox. I attempt to flash my Epox m/b with the Epox updater and everyones worst knuckle-whitener happens, the update freezes half way through! Dead motherboard. So I go buy the new Asus A7V266-E and install it. The system immediately boots up and I run chkdsk. The errors seem to vanish but a few reboots later the same problem manifests here as well. So I delete the partition, reformat NTFS and start again. Again I have no system problems getting everything up to speed and functional.

    I've constantly been running chkdsk and have noticed varying behavior on a seemingly by-run basis. I can run "chkdsk" and no errors will be reported, similarly, I can use the chkdsk gui (accessed by drive properties->test) with no errors reported but if I instantly then do a "chkdsk c:" drive errors will be found and "/F" is recommended. I can do this all day long and the results will vary constantly. Corrupt Bitmaps, unallocated space marked as allocated, corrupt this or that but most times "chkdsk" alone does not see a problem, only "chkdsk C:" does.

    If I ran a computer shop, I'd simply swap parts until I determined the issue but this can get expensive for a home user. I've long since passed my wits-end but I will not stop until this issue is identified. My next guess is that my drive has something wrong with it but all western digital diagnostics tell me it's running perfectly. People have suggested that the memory might be bad. I've read that disabling my CDROM's might help as well. Both of these things seem very unlikely to me.

    I've found several other people who are experiencing similar issues to mine here but none of these things seem to be helping.

    I have a feeling something is fundamentally wrong but can't put my finger on it because other than the "behind the scenes" corruption of the disk, everything works just fine. No crashes, no freezes, no general system instability.

    3DMark kicks out a 7583 score, all games work flawlessly. Sound is perfect. Everything is fine except for bizarre drive corruptions that will not go away.

    I've reinstalled several times since then and have recently chosen to NOT install VIA's 4in1 drivers nor their IDE miniport driver from their website. I can say with a high degree of accuracy that the IDE miniport driver will most certainly destroy your data, bootsector, master file table and anything else on your drives.

    With this, my 5th or 6th format and no updated VIA drivers, the system seems to be somewhat stable datawise, but I still find errors on my drive when using "chkdsk <drive letter>". These errors are not reported when using "chkdsk" alone. In addition, I can run "chkdsk <drive letter>" right now and it will say there were errors and when I immediately run "chkdsk <drive letter>" again, it reports no errors! Is this a problem with chkdsk per say and not related to the serious drive corruptions? Is this a misunderstood feature of NTFS and chkdsk?

    Give it a try yourself and tell me if you have errors.

    Remember to use the drive letter as chkdsk alone performs a different type of check or so I assume.

    chkdsk c:


    I'd post my own but I just ran dual chkdsk's and the errors won't reappear for a while or most certainly with a reboot as it always shows errors after a reboot.

    Does anyone have further suggestions here?

    Regards,
    ttocco
     
  2. Lonman

    Lonman Bleh!

    Messages:
    2,642
    I'd try losing the Quantum for a while and running the WD on it's own IDE channel. You're definantly not hurting for space without it.
     
  3. ttocco

    ttocco Guest

    Quantumless

    "Lose the Quantum"

    I've actually done that with the same results. There is an *exhaustive* list of things I've tried but I didn't want my original message to become so large people ignored it.

    Also, please tell me if

    "chkdsk c:"

    displays any form or errors for you.

    Best Regards,
    ttocco
     
  4. Lonman

    Lonman Bleh!

    Messages:
    2,642
    As a matter of fact it does (chkdsk c), and then recommends I run a Chkdsk /f. I'm not overly concerned about it though because I keep booting up with no problems and I'm not getting chkdsk folders stacking up in my root directory as a result of lost clusters and cross-linked files (the stuff REAL corruption is made of). It's difficult to know what chkdsk is finding because it doesn't give a real detailed report, "errors were found and fixed" isn't very descriptive.
     
  5. ttocco

    ttocco Guest

    Good news!

    Thanks Lon, for shedding some light there.

    I'd be interested to see if everyone receives these "errors".

    Also, for those interested in my original topic. As time goes by I'm beginning to think that the 4in1 drivers and or the IDE mini port driver from Via were my problem the ENTIRE time... Or so it seems thus far. Especially if chkdsk <drive letter> behaves this way on ALL NTFS XP installs. I was basing MUCH of my testing on the messages reported by this tool and it's somewhat refreshing and annoying at the same time to realize this might be SOP for chkdsk.exe.

    More as it develops.

    Regards,
    ttocco