User account disappeared from Welcome Screen

Discussion in 'Windows Desktop Systems' started by Glaanieboy, Nov 3, 2003.

  1. Glaanieboy

    Glaanieboy Moderator

    Messages:
    2,626
    Location:
    The Netherlands
    For some reason, one of the four user accounts on my system has vanished. The user's folder in Documents and Settings is still intact and when the user logs on with Ctrl+Alt+Del (instead of clicking the name), I can type in his name and the system logs on with his settings etc as normal.
    When going to 'User Accounts' in Control Panel, I tried to create a new user with the same name as the disappeared one, but then Windows says the account can't be created, because the name already exists.
    How can I reset the Welcome screen to display the missing user?
     
  2. yoyo

    yoyo _________________

    Messages:
    1,557
    If you can still logon to this account it is obviously still active.

    Check in the registry if the account is listed at

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon\SpecialAccounts\UserList

    and has a value of 0. If so change this to 1.
     
  3. Glaanieboy

    Glaanieboy Moderator

    Messages:
    2,626
    Location:
    The Netherlands
    Nope, it's not listed.
     
  4. 2z

    2z OSNN Gamer

    Messages:
    2,439
    Location:
    England
    try this *regedit
    navigate to
    HKEY_LOCAL_MACHINE \SOFTWARE \Microsoft \Windows NT \CurrentVersion \Winlogon \
    SpecialAccounts \UserList]

    Create a new DWORD value
    Value Name: the missing user name
    Data Type: REG_DWORD (DWORD Value)
    Value Data: 1

    this is usually used to get the administrator on the welcome screen
    it should work (not tested) let us know how you get on

    always back up before messing with the registry
     
  5. Glaanieboy

    Glaanieboy Moderator

    Messages:
    2,626
    Location:
    The Netherlands
    I found it out! I created a DWORD named <account name> and with a value of 1 in the reg path you specified and now it shows up! Thanks!
    I am still wondering why it disappeared though.
     
  6. Glaanieboy

    Glaanieboy Moderator

    Messages:
    2,626
    Location:
    The Netherlands
    Sorry 2z, didn't see your post :doh: