System Shock 2 Compatibility

Discussion in 'PC Gaming' started by Khimaros, Oct 15, 2002.

  1. Khimaros

    Khimaros Guest

    Has anyone gotten System shock 2 to work under win XP?

    I just picked up a copy second hand and can't get it to work.

    I downloaded the patch and have tried compatibility modes both with and without the patch applied to no avail.

    To say I'm gutted would be an understatement.

    I'm running XP pro on an Asus 266e with GF4 Ti4200.

    Please help me, I really don't want to have to install Win98 again just to play this game. :'(
     
  2. rettahc

    rettahc Guest

    Been a while since I played that. I am installing it now, will let you know if it works...........
     
  3. rettahc

    rettahc Guest

    :eek: It runs just fine for me under XP, didn’t even have to put it in compatability mode. Dont know what to tell you..........
     
  4. RobbieSan

    RobbieSan Guest

    did the problem/s happen when you tried to install or when you tried to play it?

    What I find is when I install a game older than XP I install in Win98/Me mode and it usually works well. Same thing with the patch.

    Out of curiousity, if you haven't done this, uninstall the game, explore the SS2 cd, right click on SETUP.EXE, properties, compatibility, Win98/Me. When you install the patch do the comp mode thing as well.

    If you still have problems then you may be having some driver issues. If that's the case run dxdiag and post the results of the tests here:

    start > run > dxdiag > save to text file > copy and paste results here
     
  5. Khimaros

    Khimaros Guest

    Ok i got it working

    i finally got it working using 2000 compatibility mode.
    thanks for your help guys.
     
  6. AlphaGremlin

    AlphaGremlin Guest

    No need for compatibility mode. Compatibility worked for me... until I actually started a new game.

    First off, run the setup program with the command "-lgntforce"
    Then install the latest patch. Don't run either in compatibility mode.

    I'm running XP SP1, works fine.
     
  7. Khimaros

    Khimaros Guest

    What does that command line do?

    (I'm at work at the mo and can't check....)
     
  8. AlphaGremlin

    AlphaGremlin Guest

    -lgntforce makes setup work on NT without compatibility. It also sets the game so that the patch will install the NT executable instead of the 9x one, which works without compatibility mode, on 2000 and XP.