Surround sound in Doom 3

Discussion in 'PC Gaming' started by Glass, Aug 4, 2004.

  1. Glass

    Glass sgàthan ìnnleachd

    Messages:
    101
    Location:
    A box with holes in it
    I have an Audigy 2 ZS with latest drivers and a 7.1 sound system, and I have 7.1 surround slected in Windows control panel, but when I try to select surround within Doom 3's menu, it says something like 'No surround system detected. Check Windows control panel settings' so I double checked and I definitely have 7.1 surround slected in there. I even tried manually changing the numberofSpeakers line in the DoomConfig.cfg file from 2 to 5, 6, and 7 and making the file read only, but I still can't get positional audio. Any ideas?
     
  2. Electronic Punk

    Electronic Punk Administrator Staff Member Political User Folding Team

    Messages:
    18,590
    Location:
    Copenhagen, Denmark
    Sounds like (forgive the pun) there are a few issues with Doom III's sound at the moment.

    Did you get the new ZS drivers from Creative?
    (ie less than a week old)
     
  3. Wrathchild

    Wrathchild OSNN Senior Addict

    Messages:
    338
    Had the same problem, same sound card. When I checked my speaker settings in the Creative speaker settings menu (not the Windows applet) I noticed that 2 speakers was selected for some reason. I switched it to 5.1 speakers, closed it, went into Doom, selected Surround speakers and voila! It worked fine. Hope that helps.

    -Wrath
     
  4. apu95

    apu95 Caffeine-->Code Converter

    Messages:
    502
    Location:
    Montreal, Canada
    yeah i had the same thing, but im running on 4.1...for some reason Doom 3 doesnt consider 4.1 as surround, so i had to change the windows control panel to 5.1 (it doesnt have 4.1, i dont know why) and it worked
     
  5. Nismo83

    Nismo83 OSNN AZN Addict

    Messages:
    383
    what driver are u using? I'm using the same card as yours and yes... my creative applet is showing 5.1 but getting distorted then cut off sound when i play in surround mode.