stupid logitech mouse

Discussion in 'General Hardware' started by drahzar, Sep 29, 2002.

  1. drahzar

    drahzar Guest

    K, i got a logitech optical mouse, and whenever i play cs with it, all my movements are delayed about half a second. It is not lag, computer or server. I downloaded the latest patch from logitech, i even downloaded the gaming patch from their site which said it would make it so i wouldnt have to end task em_exec. Still nothing, even when i end tasked em_exec. Anyone know what's wrong?
  2. Nick M

    Nick M Moderator

    3,961 it just in CS, or in all games?
  3. drahzar

    drahzar Guest

    Only CS
  4. Vorpal

    Vorpal Guest

    Try uninstalling the Logitech drivers and see if the same problem exists when you are back on Microsofts default drivers.
  5. drahzar

    drahzar Guest

    Tried windows drivers, tried windows drivers + cstrike fix, tried logitech drivers + cstrike fix, nada.
  6. cozwell

    cozwell Guest

    If its the cordless mouseman optical, its just a P.O.S. That came with my keyboard and the f'ing thing is worthless... if you stop using it for 2 seconds it goes into some kind of battery saver mode and you have to click to get it to wake up
  7. Goatman

    Goatman Ska Daddy

    That's odd, I have the Cordless Optical Freedom, and mine never goes to sleep that fast, usually takes 5 mins, and even then, all I have to do is move it, it then wakes up.
  8. drahzar

    drahzar Guest

    I'm usin the just optical, not cordless. I found out on cs boards that a lot of people have this problem, and there dont seem to be any good fixes... :(
  9. Vorpal

    Vorpal Guest

    I assume you've plugged in a different kind of mouse and still have the same problem??

    Maybe try changing it's connection from USB to PS2 or vice-a-versa.

    I've used four different versions of Logitech optical mice and they're all good for CS.

    Although, the above comment about the logetich cordless optical being a POS is 100% accurate.

    If this new one is as good as this review says, it will be incredible. I'm definetly going to try one:
  10. Vorpal

    Vorpal Guest

  11. drahzar

    drahzar Guest

    Haven't tried new mouse, would have to go buy one. And I tried changing ports, didn't help.
  12. Static 99

    Static 99 Guest

    Try to increase the Sample-Frequency.

    You can change this in the Device manager under the advanced tab of the mouse properties.

    See also screendump
  13. surge

    surge OSNN Senior Addict

    optical mouses are no good for playing games like Cs etc, yuor better off gettin a ball mouse to play thoes games with
  14. Nick M

    Nick M Moderator

    I agree with Surge, just get a normal ball mouse, it would work just fine.
  15. drahzar

    drahzar Guest

    Borrowed a ball mouse from a friend, still messed. sample frequency is maxed
  16. ZipTriX

    ZipTriX Guest

    If based on personal preference. I have a Dual optical mouse, by Logitech, and it works better then any ball mouse, including my boomslang.

    Try turning off the "enhance pointer precision". Once you do that you will need to adjust the pointer speed. You'll find it via Control Panel - Mouse
  17. dabomb

    dabomb Moderator

    i have a logitech optical mouse and it runs fine with all games that ive come across so far :)
  18. Zedric

    Zedric NTFS Guru Folding Team

    I've had this problem but it wasn't the mouse. Usually it goes away if I change from OpenGL to D3D or back (depending on what I was running first).
  19. john30uk

    john30uk Guest

    YES dual optical(600dpi) logitech rocks in all games just rember to set mouse or pointer accelaration to max it is low by default ,mine is optical and cordless best i have ever used get 50-60 days on duracell utra m3 batteries all other not as lond.
  20. Mubbers

    Mubbers Shoot! Political User

    I tried 'tweaking' my mouse settings and I don't think that it's simply a case of maxing the settings. Try putting the settings back to default values and see what happens.

    My standard ball mouse didn't work too well with a maxed out sample rate.

    I'd also shave to say that if your mouse works fine on everything BUT CS then it must be CS that's goosed...