Strange Problem....

Discussion in 'Windows Desktop Systems' started by Ferretlovers, Aug 29, 2004.

  1. Ferretlovers

    Ferretlovers Giver of 2 Cents

    Messages:
    40
    [FIXED]Strange Problem....

    Today I got up and my computer was acting very strangely. I would load my homepage, and not all of the elements would load, and it seemed to have an odd "feel" to it. So I gave it a restart, but when I did it seems it unassociated all of my exe's somehow. if I click on an exe or an lnk file it asks me what I want to open it with and they have that unassociated icon on each of them. The only links on my desktop that are left alive are My Computer, IE, and the Recycle bin.

    Has anyone heard of this before? Any idea of a fix?

    Take Care,
    Mike
     
  2. Tittles

    Tittles Dabba Dooba Political User

    Messages:
    6,344
    Location:
    Muskegon, Michigan
    Did u scan for a virus or adware?
     
  3. Ferretlovers

    Ferretlovers Giver of 2 Cents

    Messages:
    40
    I am doing a virus scan right now...so far nothing. I cannot run an adware scan because of the problem though.
     
  4. Lee

    Lee OSNN Proxy

    Try opening my computer>tools>folder options>view and check the box saying 'hide exstentions of known files' apply ok and close window.
     
  5. Perris Calderon

    Perris Calderon Moderator Staff Member Political User

    Messages:
    12,332
    Location:
    new york
    I would do a system restore if you haven't dissabled the utility
     
    Ferretlovers likes this.
  6. Ferretlovers

    Ferretlovers Giver of 2 Cents

    Messages:
    40
    I used pestpatroll to do an online adware scan...that came back clean.


    Take care,
    Mike
     
  7. Ferretlovers

    Ferretlovers Giver of 2 Cents

    Messages:
    40
    I found a reg file that is suposed to fix unassociated exe's. It is:
    Code:
    Windows Registry Editor Version 5.00
     
    [HKEY_CLASSES_ROOT\.exe]
    @="exefile"
    "Content Type"="application/x-msdownload"
     
    [HKEY_CLASSES_ROOT\.exe\PersistentHandler]
    @="{098f2470-bae0-11cd-b579-08002b30bfeb}"
     
    [HKEY_CLASSES_ROOT\exefile]
    @="Application"
    "EditFlags"=hex:38,07,00,00
    "TileInfo"="prop:FileDescription;Company;FileVersion"
    "InfoTip"="prop:FileDescription;Company;FileVersion;Create;Size"
     
    [HKEY_CLASSES_ROOT\exefile\DefaultIcon]
    @="%1"
     
    [HKEY_CLASSES_ROOT\exefile\shell]
     
    [HKEY_CLASSES_ROOT\exefile\shell\open]
    "EditFlags"=hex:00,00,00,00
     
    [HKEY_CLASSES_ROOT\exefile\shell\open\command]
    @="\"%1\" %*"
     
    [HKEY_CLASSES_ROOT\exefile\shell\runas]
     
    [HKEY_CLASSES_ROOT\exefile\shell\runas\command]
    @="\"%1\" %*"
     
    [HKEY_CLASSES_ROOT\exefile\shellex]
     
    [HKEY_CLASSES_ROOT\exefile\shellex\DropHandler]
    @="{86C86720-42A0-1069-A2E8-08002B30309D}"
     
    [HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers]
     
    [HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\PEAnalyser]
    @="{09A63660-16F9-11d0-B1DF-004F56001CA7}"
     
    [HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\PifProps]
    @="{86F19A00-42A0-1069-A2E9-08002B30309D}"
     
    [HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\ShimLayer Property Page]
    @="{513D916F-2A8E-4F51-AEAB-0CBC76FB1AF8}"
     
    
    only problem is that without exe's working I cannot insert that since regedit is an exe. Same problem with trying to do a system restore. GRRR....this is a rough one.

    Mike
     
  8. Tittles

    Tittles Dabba Dooba Political User

    Messages:
    6,344
    Location:
    Muskegon, Michigan
    well...when it asks for u to open it with a program go to c:\windows atleast i think that will work.
     
    Ferretlovers likes this.
  9. Ferretlovers

    Ferretlovers Giver of 2 Cents

    Messages:
    40
    I got that reg file merged, but it didn't seem to fix my particular problem.

    any more ideas?

    Mike
     
  10. Lee

    Lee OSNN Proxy

    Did it work the day before, then think what you installed or uninstalled inbetween!
     
    Ferretlovers likes this.
  11. Ferretlovers

    Ferretlovers Giver of 2 Cents

    Messages:
    40
    yes, it worked when I went to bed. I think I am getting closer to it working. I got bat file from http://www.dougknox.com/xp/tips/xp_easy_file.htm and that got me a little closer...now I have the icons back on my lnk files, but when I click on a lnk or exe it gives me the error:

    This file does not have a program associated with it for performing this action. Create an association in the Folder Options control panel.

    I am going to try that reg that I posted here again to see what it does then.

    Take Care,
    Mike
     
  12. Ferretlovers

    Ferretlovers Giver of 2 Cents

    Messages:
    40
    WOOO!!!

    All fixed now!!

    Thank you everyone for the help.

    Take Care,
    Mike
     
  13. dreamliner77

    dreamliner77 The Analog Kid

    Messages:
    4,702
    Location:
    Red Sox Nation
    for future reference, if .exe's won't run, try changing file ext to .com and running it.