Slow boot & Networking?

Discussion in 'Windows Desktop Systems' started by scriptasylum, Feb 12, 2002.

  1. scriptasylum

    scriptasylum Moderator

    Messages:
    832
    Location:
    Des Moines,IA
    Not really sure if this shouldn't be in the Networking forum but here goes:

    I have a simple 2 computer network direct from one PC to mine via crossover cat5 cable through identical Netgear NICs. Each of these PCs connect to the internet by 56k AOL. I do not want to use internet connection sharing or anything like that, the network is just there so my wife and I can multiplay a few games, file sharing, and to make PC backups easier. Simple enough.

    When her PC is NOT already on when I boot up, my boot time is pretty good (~30 sec); but when her PC is on, my boot time increases quite a bit (~2 min). The PC will boot to the login as normal, but after I type my password, it will sit there doing nothing for 2 minutes until my desktop appears. During this interval there is no harddrive activity.

    My wife's PC acts the same way; it boots great only if mine is off. If my PC is on, her boot time suffers similar to mine.

    I've tried Bootvis and all the optimization steps I can find (including the ones on this site) to no avail. I really think the network is at fault here. I do have one of her drives mapped on my system, but have tried removing the mapping to see if that helps: nada. I used the XP Home Networking Wizard to initially set up this network. Other than this boot delay problem, all seems ok with the network. I get consistently fast file transfer rates so cabling isn't the issue (I've even tried replacing the cable).

    My system is the one listed below, my wife's is an Athlon700 (slot A) with 128M PC100 (not 2100) RAM, 20Gig WD Harddrive, 4/4/24 Toshiba CDRW, SB AWE sound, Netgear NIC.

    Does anyone have any idea about how to solve this?

    Thanks in advance.
     
  2. Damn.....I wish my girlfriend played network games with me....

    Your problem will be aosmell.....i was having this problem with a 11 person network......basically aol doesn't support networks (it took me 2 hrs on the phone for them to tell me that)..... I use the network and aol just as much as each other so i couldn't pick between either one of them.....

    I played around for a bit (well about 2 months: lol) and couldn't find a way to change the slowness of the network....

    I have recently installed aol, this has helped alot and doesn't slow down my boot up anymore......the network is still slow but much quicker......which aol are u using?

    It's 2.35 am so i g2g.....try installing aol 7 but if u are already using it the post a reply and i will send other little tweaks that sped u my network a bit.....(when i say a bit....i mean a really really really small bit)

    Otherwise just get the hell off aol.......They suck
     
  3. scriptasylum

    scriptasylum Moderator

    Messages:
    832
    Location:
    Des Moines,IA
    I am using AOL 7 already, but I think you misunderstand: I'm not connected with AOL when I am playing the games with my wife. For that I use direct TCP/IP. I was just saying I use AOL so people won't think I am trying to use some type of broadband sharing.

    She just started playing last evening when she saw me playing JHeretic (I know its an old game, but the newer rendering engine looks tons better, just don't use the OpenGL setting), she thought it would be nice to fight "side-by-side". :)

    I also got her to multiplay the demo version of midtown madness 2. Not very exciting, but fun nonetheless.
     
  4. Lactic.Acid

    Lactic.Acid Guest

    Your problem has nothing to do with AOL...if you remove any mappings you will see an improvement, but part of the delay is some apps start searching for network activity, etc. Make sure you have your default internet connections set to your modem. There's also a network browsing speed-up fix or two here, courtesy our crazy arabian programmer: http://www.xp-erience.org/forum/showthread.php?s=&threadid=1518. You can also check this: http://www.xp-erience.org/forum/showthread.php?s=&threadid=1002 some duplicate info from our crazy arabian, but maybe one or the other will give you an idea if those fixes don't work.
    /Lactic
     
  5. AmarSingh

    AmarSingh Guest

    The network is at fault here. Im almost certain that you have the network settings to automatically obtain an IP address. If this is the case, assigning static ips in the range starting at 192.168.0.1 and default gateway to 255.255.255.0 will fix your problem. I have a network set up the same way using a crossed cat5 cable with my laptop and desktop and i had the same problem until i set the NIC from my desktop that was connected to my laptop to use a static IP. (i didnt for my laptop cuz im sharing a broadband connection, but u should need to set both to distinct ips). I believe that the windows DHCP server is at fault here, but im not aware of any patches that will fix it. Post back with any progress ;)
     
  6. Lactic.Acid

    Lactic.Acid Guest

    He's not running ICS so there should be no DHCP server at all. And if there were, it would time out faster than two minutes when it saw there was no connection.
    /Lactic
     
  7. AmarSingh

    AmarSingh Guest

    maybe its just me so pardon me if im wrong, but i was under the impression that if you were to network two computers without a hub and didnt assign static ips to your two pcs that windows xp has a built in dhcp server that waits for a while and then assigns ips you your NIC. Am I totally wrong here?
     
  8. Lukas

    Lukas Real Name No Gimmicks

    Messages:
    421
    Um, try to take a look at network activity while booting... Also, as mentioned above, you should asign static ip adresses to your nic's. 10.0.0.x with a subnet of 255.0.0.0 or the adresses described above. Make sure that nothing is set to automatically acquire settings, and automatic detection, like the auto-detection of proxy server etc...

    If that doesn't help, try (by trial and error) msconfig to uncheck unnecesary programs and/or services...

    My two cents...

    PS: does anybody know about the automatic IP adress assigment mentioned by AmarSingh?
     
  9. scriptasylum

    scriptasylum Moderator

    Messages:
    832
    Location:
    Des Moines,IA
    Wow, go to bed for 9 hours and get 5 more replies! Thanks everyone. I looked at my event log and DO notice a DHCP warning in there. Maybe I'll try changing to a static IP.

    I also noticed my IP stays the same, but my wife's PC seems to change IPs every so often. I configured both networks the same (automatically) so I don't know why hers does this.

    Anyway, I'll give it a shot setting static IPs and see if that helps.

    Thanks again guys
     
  10. AmarSingh

    AmarSingh Guest

    let us know how it goes;)
     
  11. scriptasylum

    scriptasylum Moderator

    Messages:
    832
    Location:
    Des Moines,IA
    Wow, I think it worked! I just went into the network properties and specified an arbitrary IP address for both my wife's PC and mine, and now they both boot up like they should with no delays!

    FYI: Even with one of her drives mapped on my pc, bootup is still great. Disabling it had no noticeable effect.

    Thanks everyone.