Sidewinders wont work

Discussion in 'General Hardware' started by avsdotcom, Jun 13, 2002.

  1. avsdotcom

    avsdotcom Guest

    A friend of mine is having trouble with a sidewinder force feedback joystick (gameport connection) and XP Pro. It will not recognise the joystick at all. He has had a look for updated drivers but to no avail. Apparently microsoft forums are full of people having the same problem with the gameport version of the stick. I use the USB version and have had no probs with it (although mine isn't a force feedback).
    Does anyone know of a possible fix/patch for this as I find it hard to believe that Microsoft would not support their own products for XP.
  2. niabi

    niabi Guest

    Does he by any chance got a USB DSL modem ?? Alcatech USB modem ??

    i have the exact same problem although it is not the same jystick, BUT if i unplug my USB modem the gamepad works and gets recognized, Alcatech is L A M E at trying to fix it, they say it is an IRQ conflict, but the modem does not seem to be using an IRQ or at least no on the device manager, not even the USB hub is using a IRQ maybe there is a way to change it but at leat not a simple way.

    've been haviung that problem for like 2 months no workaround other than unplguing the modem or taking out the drivers.

    so if you got a USB modem check that out.

  3. GoNz0

    GoNz0 NTFS Stoner

    the year 2525
    Ok do this.

    Control Panel/ Gaming devices. & select microsoft auto detect. in the add new device.
  4. niabi

    niabi Guest

    Thats kinda obious and i have tried it, no work here :D

  5. djwhite

    djwhite OSNN Senior Addict

    XP shouldn't have any problems detecting the joystick as it's drivers come with the OS, I didn't have any problems with mine and it uses the gameport not USB, although I'm using XP home, but that shouldn't matter
  6. avsdotcom

    avsdotcom Guest

    Thanks for the help, but none of the above will work, and as far as I'm aware the auto detect feature in control panel will only work with sidewinder pads (well, it works with my pad but wont work with my joystick). It does actually show up in gaming controllers as OK, but when u go to look at properties it just says that nothing is connected. Also, it wont recognise a sidewinder pad AT ALL.
    The gameport is installed and recognised so there doesn't seem to be a problem there. Any other ideas ?
  7. niabi

    niabi Guest

    Well as i said thats the SAME EXACT problem i got, the pad says OK but when i play or try properties it says not connected.

    check IRQs if you don't have an USB modem maybe it is a IRQ conflict. i think XP sucks at that, i ahd no problem on Windows ME

  8. xontroulis

    xontroulis Guest

    I have a Sidewinder Force feedback Pro Joystick and XP Pro autodected it perfectly.

    It is not a USB device, it is just normaly conneted to the Game Port...
    ..and it was even detected without being connected to the power supply
  9. avsdotcom

    avsdotcom Guest

    Update - spoke to my mate last night and he DID have a USB modem (my mistake, he's just bought it and I didn't know :rolleyes: ) He has tried it without the modem plugged in but still no luck. He even completely uninstalled the modem, but it made no difference. Needless to say, he's not best pleased 'cos he's just spent £1300 on a new system and he can't use his joystick or joypad with it. Gutted :eek:
    Anyway, I'm going down there tomorrow to watch the footy (and he's giving me his old 40 gig harddrive as he's now got 4 x 80 gig drives!!) so I'll have a better idea of whats going on then, hopefully.
    Thanks for all the replies anyway, I'll post back with the results tomorrow 'cos I'm not having it that neither of them work.
  10. kev59

    kev59 OSNN Senior Addict

    re prob

    try unpluging the game pad and delete it in game controllers in control panel then see if your joystick works hope this helps
  11. avsdotcom

    avsdotcom Guest

    He's already tried that ,but thanks for the idea anyway :(
  12. avsdotcom

    avsdotcom Guest

    Apparently yes, but when he clicks properties it says its not installed - thats with the joystick. The pad doesn't show at all.
  13. niabi

    niabi Guest

    just in case you haven't tried it, have you tried the Joypad on another PC ???

    just wondering :D