SHUT down times SLOWWWW

Discussion in 'Windows Desktop Systems' started by oO ShifterZ Oo, Aug 14, 2002.

  1. could anyone plz help me on about my shut down time, its kinda sluggish. kinda slow it maybe takes 2 min to shut down, i got xp pro. i have the settings in reg. as follows
    uner HKEY_CURRENT_USER\CONTROL PANEL\DESKTOP
    (autoendtask) 1
    (hungAPPtimeout) 5000
    (waittokillapptimeout) 4000

    is there anything i did wrong, its kidna slow.
     
  2. idonnu how do i check
     
  3. allan

    allan Guest

    Then that would be a no ;)

    Are you on a network?

    Also, look in msconfig and make sure there are no programs starting that you aren't aware of.
     
  4. NetRyder

    NetRyder Tech Junkie Folding Team

    Messages:
    13,256
    Location:
    New York City
    The timeouts that you have set should speed up shutdown considerably.

    You could also try defragmenting the drive, if you haven't done so already.
     
  5. allan

    allan Guest

    Actually those registry settings will only help with stuck aps. They will have no bearing on a normal shutdown.
     
  6. NetRyder

    NetRyder Tech Junkie Folding Team

    Messages:
    13,256
    Location:
    New York City
    Hmmm ... it did make a significant difference on my `puter after I changed the timeouts, although none of my apps hang at shutdown.
     
  7. allan

    allan Guest

    What can I tell you? The power of suggestion I guess. ;)

    Anyway, those settings are strictly for shutting down hung aps.
     
  8. yes i am on a network, and i think i might have touch the pagefile wit a tweak program but not so sure. and yes as we speak i am scan discing the drive as well as defrag. the drive. any more suggestions.
     
  9. allan

    allan Guest

    1) Systems with network connections take longer to shut down because the protocols required to connect to the network take a little time to unload.

    2) If you have tweaked your system to clear the pagefile on shutdown that would certainly be time consuming.
     
  10. Khayman

    Khayman I'm sorry Hal... Political User Folding Team

    Messages:
    5,518
    Location:
    England
    first of, try taking a 0 of those values

    also


    try this

    open regedit

    Hkey_Local_Machine/system/currentcontrolset/control

    then change waittokillservicetimeout to a lower number like 3000 or 4000 (or lower)...that way xp will wait less time before killing services as it shuts down
     
  11. allan

    allan Guest

    Regarding the above suggestion, it may or may not be helpful to you depending on what's holding up your shutdown, but you should be aware of one potential problem: if XP shuts down without sending proper notification to certain services, there is a possibility of creating corrupted data stores. While this is not a likely occurance, the possibility does exist.
     
  12. allan
    1) Systems with network connections take longer to shut down because the protocols required to connect to the network take a little time to unload.

    2) If you have tweaked your system to clear the pagefile on shutdown that would certainly be time consuming.
    ____________________________________________________

    well, i think 1) isnt a problem becuase my other machines (but not so powerful as mine) shuts down quickyly, and they are running win95 and winxpPRO.

    i think the factor is maybe 2) becuase maybe i change the settings, ima try to find the program again to change it so it wont, but if i dont do u know how to do it manulaly.
     
  13. well, i tried to search for the tweak program, i thoguht was xteq or tweakui but it wasnt, so i think that the reason for the slow shutdown time is becuase of the pagefile is being cleared during shutdown. DOES anyone know how to get rid of it.
     
  14. allan

    allan Guest

    Start - Run - Regedit

    Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

    Double-click on ClearPageFileAtShutdown in the right side pane

    Change the value to 0 (zero - to disable)

    Exit Regedit and Reboot
     
  15. hysteria

    hysteria Guest

    Allan, thanks for the tips! I just logged on to get the registry key for memory management and this thread helped. I'm always getting "not enough memory" when I shut down, but I have 256MB of RAM. Need to reset my page file.