Serv-U Is killing me! I've been on this for 2 DAYS Already!!!

Discussion in 'Windows Desktop Systems' started by XTREEMMAK, Nov 16, 2004.


    XTREEMMAK OSNN One Post Wonder

    :mad: I have the latest version of Serv-U and I've been reading tutorial after tutorial about how you should set Serv-U up to run with a router with no luck at all. I routed the ports like they said and enabled passive mode. I set my domain iP to dynamic, and the server (in serv-u) to the server's (the one I obtained through the router) ip. I connect to my self just fine, but when I try to get external access using my external IP (That is the WAN IP right?) I get nothing! Not even through a FTP client like WS_FTP, and yes I did set in Serv-U the external IP address in that box in the Advanced properties, and I did enable the ports I wanted open for Passive mode in general. Still nothing. I checked with my ISP to see if port 21 (that I'm using now) was blocked, they said no. What's going on!!! Is there still something I'm not doing? Or are my settings incorrect?
  2. j79zlr

    j79zlr Glaanies script monkey Political User

    I haven't used Serv-U, but its not that difficult setting a ftp server up. First thing is to set a static LAN IP on the PC you are using as a server. Find the dynamic rnage of ports you are using for passive mode in serv-u, then forward port 21 and the passive range to the ftp server in the router.
  3. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

    Are you trying to connect to your FTP thru a computer on the LAN but using the WAN IP? Cuz I kno I cannot do that, just get a buddy or somehting to help test it. Or in my case use my free dialup that comes with my DSL.
  4. j79zlr

    j79zlr Glaanies script monkey Political User

    as long as you have eveything setup correctly you can access your FTP server via WAN IP address.
  5. Johnny

    Johnny .. Commodore .. Political User

    Happy Valley
    look here: - This is for if you are using a linksys, but the information is general for any router.. Serv-U is the easiest ftp server to setup ..
  6. Zedric

    Zedric NTFS Guru Folding Team

    Let's do a checklist. :)

    1. Forward port 21
    2. Forward a passive range (which did you choose?)
    3. Set Serv-U to listen to port 21 on a local interface. (this is default I suppose ;))
    4. Set Serv-U to use a the passive range above.
    5. Set Serv-U to use a different IP for passive connections, i.e. your external IP. If this is dynamic, get a account and type that in instead.

    That's it.

    Now, if you try to access the FTP server from inside you LAN, using your external IP, that might not be possible at all depending on what router you have. My old D-Link worked very well, my new Zyxel can't do it. All Linux based routers I've tried won't do it either. The problem is that some routers won't route a packet out and in again.
  7. Geffy

    Geffy Moderator Folding Team

    United Kingdom
    are you using version 4 or version 5 of Serv-U??
  8. chrisbyrd

    chrisbyrd OSNN Junior Addict

    Hi there

    I've spent the last day or so having the exact same problem

    It sounds as though you have it configured correctly

    What I *eventually* found, was that upgrading the new version (v5) and configuring it exactly as you've got yours set up works perfectly :)

    I've spent the night moving 5,000 FTP accounts onto our new serv-u server and all is working fine (so far :D)
  9. koko

    koko Got Root?

    Columbia, S.C.
    if your ip is dynamic, you'll need to use a service to keep track of your ever-changing ip. i use - it's free and works perfectly. if you have passive mode enabled, you may need to forward ports 21 (or whatever you want external users to use) and 50,000 - 50,100.

    hope this helps.