Roxio Platinum

Discussion in 'Windows Desktop Systems' started by danchev, Dec 9, 2002.

  1. danchev

    danchev Guest

    Roxio Platinum

    I have downloaded the latest patches for Platinum. I have reinstalled it. I have reinstalled XP since. I reinstalled Roxio Platinum. I cannot for the life of me get a CD-RW to work correctly. It does not recognize the disk as RW. l have changed cd makes, still no luck. I lost half the files I saved on a disk, because it wouldn't recognize them. Now I can't even format the darn things. Anyone with any experience with this?
  2. Burpster

    Burpster Guest

    what kind of files are you trying to burn???
  3. danchev

    danchev Guest


    Any kinds of data files, images, etc. I have no trouble making audio CDs but the RW is the thing I'm concerned about. I want to be able to copy to them, and to change them as I should be able to. Once I copy to them, it becomes a non RW and I can't do much with them. I make sure they are not closed, too, when doing the copying.

    Thanks, guy,

  4. omgsoup

    omgsoup OSNN Senior Addict

    get nero
  5. scriptasylum

    scriptasylum Moderator

    Des Moines,IA
    When I used Roxio, I used to use DirectCD to format the CDRW's, then use Explorer to drag-n-drop the files to the CD.

    Nero is better IMO, but I'm sure you don't want to switch after paying the $$$ to get Roxio.
  6. Hipster Doofus

    Hipster Doofus Good grief Charlie Brown

    Melbourne Australia
    See how you go over here.
  7. Leevoy

    Leevoy Guest

    Did you completely uninstall Roxio before reinstalling XP?
    I know XP won't allow you to reinstall XP if you did not.
    I know Take two is not supported for XP.
    I tell you how I got mine going.
    I uninstalled Roxio easy cd creator Platinium V5.1.
    I rebooted.
    I uninstalled sp1 xp. Rebooted.
    I then used Regcleaner (reinstalled as so it works correctly with xp pre sp1). rebooted. Home page for regcleaner is
    By default when you open RegCleaner it displays software.
    I checked adaptec and anything that is linked to easy cd creator and removed entries.
    I then hit my computer/programfiles/commonfiles/then anything in the folders to do with adaptec easy cd creator and deleted them.Mine has a folder saying adaptec shared.
    I then hit start then search (searched the name adaptec and removed the files to do with adaptec easy cd creator 5.1).
    I then ran Regcleaner under the tab tool/registry clean up/do them all and removed all entries it bought up.

    Reinstalled easy cd creator V5.1 with take two unchecked but even though it says direct cd is not supported kept the option as the patch is available for that.
    Then I applied the patch and rebooted.
    Installed xp sp1
    Checked windows updates or installed any I had saved from after sp1 install yeah when windows update site says you need no more updates I rebooted, defragmentated my HD and cleaned up all temp files etc...(optional) and started burning yeeee ha.

    Worked for me, maybe you find my ways strange, but if it works for me should work for you.

    I have nero (o.e.m. with my dvd+rw/+r drive) but I find roxio easyier and sexier, lol, thats why i use it.

    I have seen roxio has a set of updates for their software it can be seen here:

    Version 6 is out but cannot see them really making a dent on Version 5.

    Good luck with it regards Leevoy:))))))))))))

    Be sexy everyone, you only live once.
  8. Octopus

    Octopus Moderator

    disable the built in burner from Roxio in might cause some kind of conflict.
    otherwise get Nero
  9. danchev

    danchev Guest

    Hmm, wow, worth some tries for sure. Thanks, I will do just that,