root cannot run "startx" or "startkde"

Discussion in 'Linux & BSD' started by XxFirebrandxX, Jul 13, 2005.

  1. XxFirebrandxX

    XxFirebrandxX I am a MONKAY!

    Messages:
    15
    Location:
    Pennsylvania
    I'm confused why I can use startx and startkde from users other than root. When I try running these commands as root it returns the DRIScreenInit Failed. Disabling DRI.

    Also, I think this may be linked to a permissions problem because when I am inside KDE with another use, I cannot su or change to administrator mode. Can anyone help me with this? Thanks in advance!
     
  2. Geffy

    Geffy Moderator Folding Team

    Messages:
    7,805
    Location:
    United Kingdom
    its probably a security feature to prevent you from running your GUI system as the root user which is an inherently bad idea

    su'ing to root, is the user you are running as a member of the wheel/root group?
     
  3. Howling Wolf

    Howling Wolf We did not deserve this !

    Messages:
    1,243
    Location:
    Amongst the Native Ones
    Strange, I have Debian (Sid) installed on my 2nd hdd and as I've installed KDE from command line as root, I'm able to run "startx" from there. I've done it several times only for test purpose, of course I usually log in as Howling Wolf ;)
     
  4. ThePatriot

    ThePatriot -=[BOHICA!]=- Political User

    Messages:
    1,742
    Location:
    Pennsylvania
    Geffy's right, it is most likely a security issue...but I regularly run "startx" as root in Unixware and RedHat 9 with no prob. I take a look at my work machines tomorrow and see if I can find anything.
     
  5. X-Istence

    X-Istence * Political User

    Messages:
    6,498
    Location:
    USA
    It is probably a new security feature in X.org and would probably not exist in XFree. Which is why older systems with XFree would not have the problem. I tend to never run X.org as root in the first place, but i am thinking it is a security related problem as well.
     
  6. XxFirebrandxX

    XxFirebrandxX I am a MONKAY!

    Messages:
    15
    Location:
    Pennsylvania
    Ok, I found the problem why I couldn't use KDM. I was able to use XDM which was strange, so I fooled around with the KDM configuration and found an option in kdmrc where it says on a line something similar to:

    AllowRootLogin: False

    So, I changed it to true and am able to use KDM to login.
     
  7. karl_axe

    karl_axe OSNN Addict

    Messages:
    75
    i believe that's what kdm is missing... GDM has that option to allow root logins or not.