RealVNC

Discussion in 'Windows Desktop Systems' started by kid312, Aug 22, 2004.

  1. kid312

    kid312 OSNN One Post Wonder

    Messages:
    9
    Hey,
    I can connect to other computers on my network alright (with IPs like 192.168.#.##) but how do I connect to a a computer from outside the network? To my knowledge, a single IP is assigned to my network so how exactly do I connect to a particular computer (with server running)?

    Also, what's a port?? RealVNC connects through port 5800 or something right? Is that on the client, the viewer or both? I ask because I need to allow use of the port through my firewall right?

    Thanks
     
  2. cryogenic

    cryogenic OSNN Addict

    Messages:
    241
    Location:
    TN, blah!
    I use TightVNC, but this info should apply here.. Basically if you wanted to connect to a computer INSIDE your network from elsewhere not on your network, you have to forward the port on your router to the computer that is running the VNC server. If you wish, you can setup VNC servers on each and every computer on your network but on a different port for each. Then after you have the port forwarded and the port open in your firewall (it's a port for the server), then you should be able to connect from outside the network. Connect to whatever your outside IP is (it WON'T be a 192.168.x.x IP) and it will automatically forward you to whichever computer the port is forwarded to. If you have set the server up on a port other than default, then you connect to your WAN IP and append the port # onto the end of it in the connect box... Here's an example.

    **Say the computer you want to run VNC on is 192.168.0.147 and your IP to the outside world is 68.47.207.156
    1) on that computer, setup the VNC server...
    2) Open port 5800 on any firewalls you may be running (or just set winvnc.exe as an exception).
    3) Forward port 5800 on your ICS computer or your router (whichever you use) to 192.168.0.147
    4) from outisde the network, run vncviewer.exe (that's the only file you need installed) and enter 68.47.207.156 in the connect to: box.
    5) you should then be connected to the computer running the VNC server.

    as a side note, if you opt to use an alternate port for running the VNC server... let's say you opt for port 7025. You would then enter 68.47.207.156::7025 in the connect to box. YES, you use double-colons, that's not a typo.

    If you need more help, feel free to contact me on AIM or Yahoo (use the links to the left)
     
  3. kid312

    kid312 OSNN One Post Wonder

    Messages:
    9
    Port Forwarding

    I have a router so I guess I need to enable port forwarding. How exactly do I do this? Don't know if its relevant but I have a wireless router.

    Also, just curious....if I had two comps running (in the same network) with the same port specified in the RealVNC settings, what would happen if I tried to connect to one of them from outside the newtork?

    Thanks again
     
  4. cryogenic

    cryogenic OSNN Addict

    Messages:
    241
    Location:
    TN, blah!
    I'm not familiar with every single brand of router, but in general you'll want to use your browser to connect to the router's IP (for example, 192.168.0.1 on some routers). Login to the router, then you'll USUALLY see a "port forwarding" tab. Go to that particular tab and you'll have a set number of ports you can forward. Enter the port you wish to forward (whatever port you're running your VNC server on) and the IP address of the computer to which you intend to forward the port. Save the config and you should be all set. What brand is your router? Perhaps I can give more specific instructions knowing that.

    As far as having 2 comps running RealVNC using the same port... whichever comp you forwarded the port to would be the only one you could connect to. Note that you should not be able to forward the same port to two different computers in your router's setup. If you want 2 comps to be running servers, set them each up on different ports and then forward the ports to their respective computers.
     
  5. kid312

    kid312 OSNN One Post Wonder

    Messages:
    9
    RealVNC ports

    Hello again,
    Well I have a Microsoft Wireless Base Station - MN-500.
    I found the port forwarding tab and it has two types of port forwarding:
    -Application-Triggered Port Forwarding
    -Persistent Port Forwarding

    I attached a screenshot of the data I am required to provide for both types.

    Thanks....I truly appreciate all the help :)
     

    Attached Files:

  6. cryogenic

    cryogenic OSNN Addict

    Messages:
    241
    Location:
    TN, blah!
    I'd say just for simplicity, use the persistent option. Application triggered, as it says, would be better for games that actively make an outbound connection and expect return connection on multiple ports... VNC doesn't do that. VNC sits idle until you connect to it. Hence, use persistent. Btw, I like the setup on that MS router. nice.
     
    kid312 likes this.
  7. kid312

    kid312 OSNN One Post Wonder

    Messages:
    9
    Ports

    What data do I enter into what field?? First off all the slots for Persistent Port Forwarding are already being used (by default). I looked it up for other routers and there are only two required fields (port and local IP). For mine there is stuff like "Inbound port" "Type" "Private IP" "Private port", etc What goes where? :confused:

    Thanks
     
  8. cryogenic

    cryogenic OSNN Addict

    Messages:
    241
    Location:
    TN, blah!
    Inbound port and private port can both be whatever port you want to run the VNC Server on. The only time they would differ would be in a weird situation where you wanted people to connect to your public IP on port 6969 and be connected to an FTP running on an internal computer on port 21. Make sense? Private IP would of course be the IP address of the computer that's running VNC. Honestly, with that router (I really like that setup) you could forward port 8020 (for example) to a computer internally (let's say 192.168.0.20) on the default port. You wouldn't even have to alter the server setup on the local computer... all your computers could be running VNC on the default ports and just connect to a different port from the outside and they'd be forwarded appropriately. Make sense? Seriously, you can IM me on AIM or Yahoo and get a lot quicker response.
     
  9. kreepy20

    kreepy20 OSNN Addict

    Messages:
    99
    Location:
    South Carolina
    What router are you using?
     
  10. kid312

    kid312 OSNN One Post Wonder

    Messages:
    9
    Almost working

    It seems to be working to some extent. When I attempt to connect to a computer within my network by specifying the external IP and port it seems to try and connect but eventually (after about 10 seconds) returns "Connection timed out". When I specify some non-valid port it returns an "Unable to connect to host" error almost immediately. From this I know the port forwarding is set up properly (or at least I think it is).

    NOTE: I am trying to connect from a computer that is within my network to another one in the network but with external IP (NOT 192.168.x.x). Connecting with internal IP and port works fine from comps within LAN.

    kreepy20, I have a Microsoft Wireless Base Station - MN-500

    cryogenic, I added to your reputation thing :)
     
  11. cryogenic

    cryogenic OSNN Addict

    Messages:
    241
    Location:
    TN, blah!
    what ports do you have setup and where? Can you connect directly to the other computer via the internal IP addres? I would assume so. Also, which method are you using? Are you using the same port in both forwarding blanks on the router? Or are you forwarding one port to another? It sounds to me that the problem is on the router's end (though maybe not a "problem" with the router if that makes any sense). Also, is this computer on a wired or wireless connection?
     
  12. kid312

    kid312 OSNN One Post Wonder

    Messages:
    9
    Vnc

    The attachment has the port forwarding setup for my router. If my thinking is right, external IP along with port 5900 should be forwarded to the comp with internal IP 192.168.2.23.

    Yes, I can connect to other comps via the internal IP.

    The comp I am using (192.168.2.26) is on a wireless connection.
    The comp I am trying to connect to (192.168.2.23) is wired straight to the router.
     

    Attached Files:

  13. cryogenic

    cryogenic OSNN Addict

    Messages:
    241
    Location:
    TN, blah!
    your port forwarding looks good to me.. Are you trying to connect to the computer from outside the network? Or are you trying to connect from inside the network to the external IP, which would then bring the connection back into the network through the router? That's effectively making 2 passes through the router and across the higher latency wireless connection twice. That COULD be the source of your problems. The fact that you can connect from 192.168.2.26 to 192.168.2.23 directly tells me that your server is setup properly. My question is are you connecting to your external IP (say 68.60.200.120) from 192.168.2.26? I'd actually suggest finding someone else who you know, setting the server to view-only and then just testing to see if they can connect from the outside.
     
  14. kid312

    kid312 OSNN One Post Wonder

    Messages:
    9
    Yup. Thanks a lot. I can connect just fine from any comp outside my network.
    One last thing....I was thinking I should have a port setup for each of the comps in my network so how should I go about doing this?
    Should I change the "Incoming connection port" for each computer and have a corresponding port setup on my router or....leave the default port of 5900 and have all Inbound ports simply forward it to 5900.

    and do I have to worry about what port I assign? Should I just assign 5900, 5901, 5902, etc.?
     
  15. cryogenic

    cryogenic OSNN Addict

    Messages:
    241
    Location:
    TN, blah!
    You have two options... You can leave them all on 5900 or you can change the server ports. I would say leave the server ports alone, then just have, say, port 5901 forward to 5900 on 192.168.0.121, 5902 forward to 192.168.0.122, etc... it saves the configuration hassle on the server end and if you connect computer to computer, you don't have to remember what port each server is on.
     
  16. kid312

    kid312 OSNN One Post Wonder

    Messages:
    9
    Ok, thanks for all the help.
    I just have one last question....I enabled file sharing with other comps in my LAN and I can access other computers just fine but I can't access this comp from any of the others. I must have changed a setting or something. I know its not my firewall since the problem persists even if I disable it (ZoneAlarm). Any advice/help?
     
  17. cryogenic

    cryogenic OSNN Addict

    Messages:
    241
    Location:
    TN, blah!
    Are they all running home/pro? Do you have the guest acct enabled or disabled? If you have the guest acct disabled and simple file sharing disabled, you more or less have to have all the same usernames on all the computers so they can authenticate to access resources. The first suggestion I would have would just be to make sure simple file sharing is on.
     
  18. kid312

    kid312 OSNN One Post Wonder

    Messages:
    9
    File sharing

    Thanks. I got it working......it was my firewall after all. A process (vsmon.exe - TrueVector Service) was running even after shutting down ZoneAlarm. Killing this process allows others to access my comp.

    Thanks for all your help. :)
     
  19. cryogenic

    cryogenic OSNN Addict

    Messages:
    241
    Location:
    TN, blah!
    Ah, I was making the assumption that you had shut down ALL elements of ZA. In actuality, when you think you've closed ZA, you're only shutting down the GUI portion. As you found out, you have to shut down the TrueVector service too.