Problems with Win2k dualbooting after applying XP SP1.

Discussion in 'Windows Desktop Systems' started by noija, Sep 12, 2002.

  1. noija

    noija Guest

    This is incredible. Running Windows 2000 Pro on my E: partition (30GB drive) and Windows XP Pro on D: (60GB drive). Everything worked FINE until i installed XP SP1 yesterday. Now Windows 2000 doesn't boot. I get the exact same message as "Kuja" does.

    --
    Windows 2000 could not start because the following file is missing or corrupt:
    \WINNT\SYSTEM32\CONFIG\SYSTEM

    --

    Since all partitions are NTFS the first thing i looked for was file system rights. Looks like SP1 has changed all the rights all over the E: partition. So I gave "everyone" full control on E: just for now. Still no go. I just don't know what to do now. Has anyone got any ideas?

    Thanks SP1 for successfully sabotaging my computer.

    /noija
     
  2. noija

    noija Guest

    Hmmm. Problem solved?

    I found this on support.microsoft.com:

    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q124566

    while this is refering to Windows NT 3.1 and 3.5 it must be something similar between XP and 2000. Seems like XP SP1 copies new ntldr and ntdetect.com files according to C:\WINDOWS\svcpack.log. Could it be that XP and 2000 has the same "problem" as the old windows versions? Not that unbelivable huh?

    I'm going to try bootdisks and filecopying tomorrow. Now I have to sleep. Night night.

    /noija
     
  3. Kuja

    Kuja OSNN Addict

    Messages:
    163
    Which OS did you install first?

    I just said screw it, and formated C and D...... ill stick with 2k for now, if i find something that doesnt run on it, ill install a clean xp.

    I hope they release a fix for this, since other people are gonna get screwed as well. :(
     
  4. Adam S

    Adam S Guest

    just dual boot xp and .net, thats what i do ;)