Problems shutting down XP: It shuts down like 95

Discussion in 'Windows Desktop Systems' started by Punkrulz, Mar 31, 2002.

  1. Punkrulz

    Punkrulz Somewhat eXPerienced

    Messages:
    790
    Location:
    Woodbury, NJ
    For all of you old time users, you know that Windows 95 basically did not have an auto shut off like 98. 95 Basically whenever you shut it down, it would go to a screen stating that it is now safe to turn off the computer. I find this shocking, but XP has the same thing.

    Personally the XP on my computer shuts down fine. Granted its really slow to shut down, but I can click shut down and hop into bed, and it will shut down on its own. But, I have installed Windows XP on two other systems, and on both of those systems you get the screen telling you that it is safe to turn off.

    Since I know that my system turns off how it should, there has to be a way to make XP do it. Has anyone else had this problem? Is there a way around it? I am using XP Professional.
     
  2. Grifter

    Grifter Guest

    I had the same problem once with my first install of XP Professional also, and that was because I had ACPI mode disabled within my BIOS settings.


    That's most likely the reason why your other computers will not power off on their own, try enabling the APCI mode within your BIOS, the option should be within your Power Managment area of the BIOS. Hopefully then XP will shut those computers off without having to reinstall XP (which I had to do in order for it to power off in my own case for some odd reason).

    That should be all you need to do. Also, as for the slow shut down, if your using a Nvidia graphics card, you can disable the Nvidia Driver Helper Service within your Administrative Tools -> Services settings. It shouldn't cause any problems with your PC and it should give you a faster shutdown, it worked for me and countless others.

    Good luck.
     
  3. Qumahlin

    Qumahlin Moderator

    Messages:
    2,006
    Yup, Grifter's right, if it's not shutting down there is a ACPI/APM problem..also after you've killed the nvidia service

    change the key waittokillservicetimeout to about 3000...I'm sorry but it's late and i'm too lazy to find it..it's something like local machine/system/controlset001/control

    but you can search for it :)
     
  4. Punkrulz

    Punkrulz Somewhat eXPerienced

    Messages:
    790
    Location:
    Woodbury, NJ
    Welp guys, didnt work.

    I was working on the computer that I have the availability to. I go into her BIOS and there is no option for ACPI / APM. I do a search for Windows XP ACPI in the help files, and I come across that there is an option on the control panel for APM.

    So, I go into the control panel, then to the power applet. In there, I click the APM tab, and then it tells me that my computer hardware reports that I have APM support. I click the checkbox that says to use APM support. I try to shut down her computer, and it just reboots. Clicking shutting down reboots the computer. :( No ACPI in her BIOS.

    Also, for my slow shutdown (This is on my computer) There are no Nvidia graphics, I use a voodoo3. It used to shut down fine, but I dunno. I also have my dialup connection in my startup folder, but it doesnt open the connection window, its' as if it ignores it. Its selected in MSConfig too.
     
  5. Punkrulz

    Punkrulz Somewhat eXPerienced

    Messages:
    790
    Location:
    Woodbury, NJ
    One thing I notice now is in the Power Applet. Under my Advanced, it has the option to prompt password when returning from standby. On the bottom of the window there are also selections you can make, in which you can choose what happens when you click the Shut down and Stand By button. I DONT have the APM tab on my computer.

    On my sister's computer, the Stand by button isnt highlighted, you cant select it when clicking Shutdown. Also, she doesnt have the option to prompt for password when returning from resume, and she doesnt have the drop down boxes that ask what you want to do when you click stand by / shut down. :(
     
  6. allan

    allan Guest

  7. Miles_Binck

    Miles_Binck Guest

    Something else you can try (I havent seen it mentioned) is go into the Device Manager and click on:

    View --> Show Hidden Devices

    you 'might' have an option come up labelled

    NT APM/Legacy Support
    -->NT APM/Legacy Interface Node


    If this comes up right click on the 'Interface Node' line and then choose properties. Then click Enable Device (from 1st Screen), then restart the PC. This should allow the PC to shutdown properly without instantly rebooting.

    This is how my machine is currently (although I need this disabled to allows multiple users logon to my PC), and the PC 'does a Windows 95' on me as well.
     
  8. bossdodgers

    bossdodgers Guest

    Are you using an Nvidia GEFORCE 2 with the latest drivers by any chance on your system?
     
  9. Static 99

    Static 99 Guest

    I have an option in my (old) AWARD BIOS under 'Power Management Setup" : Reserve IRQ 9 yes/no.

    If i select yes (before a fresh install!), everything works fine.
    But if i select no, i don't have the APM tab, and i get a nasty systemlog error!
    So, for me it works like a ACPI turn on/off switch.
    It has something to do with the way XP/2000 assigns the IRQ's.

    more info: http://www.swynk.com/friends/tulloch/articles/ACPIhal.asp

    Also, i have an BIOS option "PM Contol by APM" yes/no
    If i select yes, XP shuts down directly.
     
  10. gonaads

    gonaads Beware the G-Man Political User Folding Team

    The two installs you did, are they on machines with ATX Motherboards with AXT power supplies or Baby AT boards and power supplies? If they're on AT power supplies it will not auto shutdown. Only on ATX power supplies.
     
  11. ikester7579

    ikester7579 Guest

    Go into control panel/system/hardware/device manager. click on computer/ right click on advanced configeration and power interface/ select update driver/ select advanced/ select don't search/ then highlight standard pc/ click next/ follow instruction and reboot. If this does not work go through same proceedure and put back in the advanced configeration and power interface. Hope this helps. ikester