Problem with right click options

Discussion in 'Windows Desktop Systems' started by lynchknot, Sep 2, 2003.

  1. lynchknot

    lynchknot Moderator

    Messages:
    800
    Hello, I have a problem (xp-pro). My right click "open with" is present but does not call up a dialog.

    Thanks for your help.
     
  2. lynchknot

    lynchknot Moderator

    Messages:
    800
    This is a problem with any file - avi, xul, etc...........
     
  3. Teddy

    Teddy Boogie Nights...!

    Messages:
    1,551
    Location:
    London, UK
    Can you post a screen shot of what is happening?
     
  4. lynchknot

    lynchknot Moderator

    Messages:
    800
    There is nothing to post. If I right click some files to seek "open with" dialog and click on it, there is no dialog window that opens. I don't get any alternative options to open the file.

    For instance, I want to open an AVI with a different player but I can't do it through the right click "open with" anymore - I does not appear.
     
  5. Hipster Doofus

    Hipster Doofus Good grief Charlie Brown

    Messages:
    5,920
    Location:
    Melbourne Australia
    Highlight the file then hold the shift key then right click. Do anything?
     
  6. lynchknot

    lynchknot Moderator

    Messages:
    800
    Hi. I tried that. What I am saying is that I can right click an AVI file and the option to "open with" is on the menu. Upon clicking "open with", nothing happens - no dialog, no other options, nothing.
     
  7. Hipster Doofus

    Hipster Doofus Good grief Charlie Brown

    Messages:
    5,920
    Location:
    Melbourne Australia
    See how this goes. Back up the reg fist....just in case.

    Open With - Not Working or Listed

    Check your settings here:

    HKEY_CLASSES_ROOT\Applications. Select the associated sub-key, if 'NoOpenWith' is listed, delete it.

    This setting allows you to control whether the checkbox to save the "Open With" program is available when an unknown file type is opened.

    HKEY_CLASSES_ROOT\Unknown\shell\openas\command

    To enable the checkbox set the (Default) value to "rundll32.exe shell32.dll,OpenAs_RunDLL %1".
    Return to the desktop and press F5 for the change to take effect.
     
  8. lynchknot

    lynchknot Moderator

    Messages:
    800
    Thanks Hipster Doofus, but everything there looks proper already.