problem with PatchXP

Discussion in 'Windows Desktop Systems' started by Mage15, Dec 21, 2002.

  1. Mage15

    Mage15 Guest

    For some reason, when I try to use this patcher, it seems to just rename uxtheme.dll to uxtheme.bak and then reboot - leaving the system unusable because the library was renamed. I've searched my system for the patched library, if it was patched it's not on my system anymore.

    The system is running Windows XP with the Service Pack 1 downloaded as a network install (the 130+MB version, Setup application was xpsp1_en_x86.exe) from MS's website. Before updating to SP1 all theme-related additions (StyleXP/Builder, TGT's uxThemePatcher) were removed and the original DLL was restored so I think I can rule those out. Also DLLcache was emptied before and after SP1 installation.

    Anyone else have this problem and have a solution?
  2. Yes, that's exactly what happens with my system (I have two messages here but no answer yet).

    I have tracked what actually happens. The patcher properly does its work. It renames the .dll to .bak and places another one instead. However before I can even press "Reboot", XP's file guard comes up and complaints that some other application has replaced crucial System-Files. It then deletes the new dll and leaves the system almost unusable (You still can press CTRL+ALT+DEL, go to Task-Manager and start a new task "COMMAND". Then from the DOS-BOX You can rename the .bak to .dll and after a reboot the system is back again).
    The dialogue prompts for the SP1-CD but at that time normally
    the system is already shutting down - so You don't see it.
  3. Mage15

    Mage15 Guest

    Yes, that was my observation as well. I even tried writing a little pascal program to capture the new DLL before WFP zaps it but so far no success, even in safe mode. If I could it'd probably be easy to get it working. I may just revert back to the original XP if I can't figure it out.
  4. Farfnarf

    Farfnarf Guest

    I'm new here :cool: and following this conversation closely.:(

    I had to re-install XP off the disk, then I went up and got sp1, knowing I'd have a hassle getting themes to work again.:mad:

    I was right.. I tried the patch and ended up with no desktop, just the wallpaper, as I've seen described here.

    I'll be checking back frequently for some help.. and I just want to say ahead of time that any help is greatly appreciated.

    I also appreciate having a nice, fast loading forum like this to talk about all this stuff on. :happy:

    Catch ya later,

    ---- Farfnarf
  5. Hipster Doofus

    Hipster Doofus Good grief Charlie Brown

    Melbourne Australia
    Did you people apply the patch before or after installing sp1? If before then apply it again.
  6. Everything was set before the patch has been installed.
  7. DoNuTjC

    DoNuTjC OSNN Addict

    I had the same problem but this is what I did and it worked...

    I have sp 1 installed and I ran the PatchXP but didn't reboot right away... When that messege comes up about trying to reinstall the dll just hit cancel and another message comes up saying something like are you sure... just click yes or ok (whatever it was) then goto start/search and search for the uxtheme.dll file and as long as it comes up then your cool just go ahead and reboot...

    hope this helps
  8. Hipster Doofus

    Hipster Doofus Good grief Charlie Brown

    Melbourne Australia
    That should do it DoNuTjC. I don't know why so many people are having trouble with the patch. It works first time for me. :confused:
  9. I did try something like that. However when the message comes up there is no .dll anymore. It gets deleted before that. By that time only the .bak exists witch is the original one.

    I'll give it another try when I have the time. Thanks so far.
  10. Hipster Doofus

    Hipster Doofus Good grief Charlie Brown

    Melbourne Australia
    Frank check out the official patch xp thread started by andyp. There is a link towards to end of it which should help. :)
  11. Jazzhound

    Jazzhound Guest

    Hi lads, I have a similar problem which I started a thread about (perhaps I should delete it now having seen this one).

    Problem is quite similar, but with me I applied the patcher/uxtheme hacker (whatever you call it) before I applied SP1. After doing so, my .dll files remained intact (as far as I can tell), however the new themes do not seem to take effect. Trying to re-apply the hack was the next logical step, but I get an error message saying:

    Obviously the SP1 rendered my build and cuased the errorenous message but seeing as how you folks have had some problems and issue with this new patcher, I'm abit hesitant, or is it the same patcher all along ?

    I just don't want to have to reinstall XP again (just wen through it 2 days ago).