please help!!! MSC problem

Discussion in 'Windows Desktop Systems' started by rhenk, Oct 23, 2002.

  1. rhenk

    rhenk Guest

    Hi, I've got a really annoying problem. It seems that I cannot run files with the MSC extension of my indows XP. I mean, the "Services" program and all the "Administrative Tools" of Windows XP don't work. Also when I try to acces de "Hardware" tab on teh Control Panel there is the same error. The Search tool also don't work, and the Windows XP Help does not work too.

    When I try to run any .MSC (Microsoft Management Console files) I get always the same error: "MMC cannot open the file C:\...\Services.msc. It may be that the file does not exist, it's not a MMC console, or it was created by a newer version of MMC. Also it can be that you don't have enough permissions to open the file" (I'm sorry for my transalation, but my Windows XP is not english).

    So please, please, please. What can I do? Does anybody know what has happened? I haven't installed anything, so how can I repair that problem (I don't want to reinstall WXP)? Thanks in advance for any help.
  2. allan

    allan Guest

    Well, something caused this to happen - it's very unlikely your system decided to rebel all by iteself. Here are some steps I can recommend. You can try each in order and see if it works:

    1) The least likely to work but easiest to try is a system restore. See if you have a restore point from just before the problem(s) arose and if so, use it.

    2) If that doesn't work, go to Start - Run and type: sfc /scannow (and press ENTER).

    3) If the probem is still there, you should do a repair install. Boot to the XP CD and right after loading it will recognize that XP is already installed and offer you a repair option. DO NOT take this option...instead, proceed with the installation. Two screens later you will again be offered a Repair Option - this time, take it (press "R"). XP will install on top of itself and your programs and preferences should remain uneffected.
  3. Khayman

    Khayman I'm sorry Hal... Political User Folding Team

    Does Mmcndmgr.dll exist on your system?

    Try running regsvr32 /u Mmcndmgr.dll to uninstall it then regsvr32 Mmcndmgr.dll to
    register it.