Office CD needed for every new user in XP?

Discussion in 'Windows Desktop Systems' started by Wicked00, Mar 27, 2002.

  1. Wicked00

    Wicked00 Guest

    Ok, office xp is installed in every computer, but yet when a new user gets on it and clicks on the shortcut to some office stuff (excel, word), theres a message that says: Insert the Office XP cd.

    Is there any way to fix this?
  2. Wicked00

    Wicked00 Guest

    This is the exact error it gives:

    MicroSoft Word has not been installed for the Current User. Please run setup to install the application

    SP1 has been installed on this computer, and all the other ones. Anyone know what could be causing it?
  3. gajef

    gajef OSNN Addict

    there are several things with office xp which can lead to such behavior:

    When you install office just default some items are only installed 'on first use' :( so to prevent that

    make sure that when you install office you use the customized setup and set all the needed options to 'run from my computer'

    If needed install servicepacks etc.

    If this doesn't resolve the question you could tweak the default user profile:

    Make a test account (with the same rights as you're normal users)
    Log on with test account and run office (e.g. word)
    Sometimes (especially when servicepacks are installed) it will ask for the office cd-rom.

    After you have succesfully started office xp log off and log on as an administrator.

    Now go to 'c:\documents and settings\Default user' and copy ntuser.dat and ntuser.dat.log to a save spot

    Copy the ntuser.dat and ntuser.dat.log from the testaccount over to the default user ones

    Now remove the total directory 'c:\document and settings\<test user>

    Try to log on as the test user and see if all works fine (i know that sometimes the quicklaunch bar is not updated :( )
    Tweak the profile of the default user until you are satisfied by doing the 'loop' of copying ntuser.dat/delete testaccount profile/log on as testuser/tweak/log off/

    After you are satisfied remember to delete the testaccount (not only the profile, but also the loginaccount)

  4. Wicked00

    Wicked00 Guest

    We'll give it a try and get back to ya. Thanks for the info.
  5. Wicked00

    Wicked00 Guest

    You cannot copy ntuser.dat to other profiles since we are using roaming profiles, and those are the files which specify all the other user's settings. Therefore, that isn't an option.

    Thanks for the help though.
  6. gajef

    gajef OSNN Addict

    To bad...

    I knew their was something why i didn't like using a roaming profile ;)

    The only thing i can think of is something like:
    create a snapshot of the registry (e.g. use
    regshot )

    update office xp

    use regshot again and compare changes under HKEY_CURRENT_USER\Software\Microsoft\Office\10.0

    create .reg file and import it into other user pofile

    It all depends on how many workstations you have if this is worthwile to investigate....

  7. Akash

    Akash OSNN Senior Addict

    It has nothing to do with roaming profiles.
    i have a network setup in the house but only for file/printer sharing.
    there are no roaming profiles.

    one machine has 4 user accounts as its a guest type machine.
    but those are not roaming profiles.

    anyway to the point, the SP1 fixed the problem which you are getting...
  8. NewGuy

    NewGuy Guest

    You can always uninstall office, copy the contents of the cd to your hard drive. Something like,


    Install from there, not the cd. Take the cd out. Do that on each machine. Now everytime it needs the cd it'll look under c:\officecd instead of d:\ or whatever your cdrom drive is, so it won't even need the cd for it.

    There's a setting in the registry you could change, but not sure where it's at. If you look for it, it'll say something like installpath d:\

    Just change d:\ to c:\officecd or where ever you copied the office cd to, and it won't ask for the cd anymore, because it'll just copy whatever it needs from your c:\officecd path.