New Audigy 2 and Audigy 2 ZS Drivers

Discussion in 'Windows Desktop Systems' started by Goatman, Mar 30, 2004.

  1. Goatman

    Goatman Ska Daddy

    Messages:
    676
    This update contains additional features and fixes to improve the performance of your Creative Sound Blaster® Audigy® 2 or Audigy 2 ZS series audio card.

    Fixes

    * Resolves the issue of THX® Setup Console resetting to default values whenever it is launched.
    * Removes noise and distortion when THX Setup Console is used.
    * Synchronizes the settings between EAX® ADVANCED HD™ and Creative Graphic Equalizer.
    * Enables MIDI device name display in Windows® Multimedia Device and SoundFont® Bank Manager.
    * Enables the activation of imported EAX effect presets.
    * Resolves the audio mute issue that is encountered when certain EAX effect presets are activated.
    * Resolves the system stall issue that is encountered when rewinding or fast-forwarding DTS®-encoded audio CDs, on external DVD players that are playing back through your audio card.
    * Enhances the performance of PC games that use native OpenAL API extensions.

    Drivers
     
  2. devynal

    devynal The Idiot Circus Boy

    Messages:
    114
    Hrmph~

    I get no sound with these new drivers. :confused:
     
  3. indyjones

    indyjones OSNN.net Adventurer

    Messages:
    1,567
    Location:
    England
    I think i will avoid them as I had problems with the previous drivers decreasing the sound volume too much pain in the ass for movies
     
  4. GoNz0

    GoNz0 NTFS Stoner

    Messages:
    2,781
    Location:
    the year 2525
    wierd, it's fixed all the issues i had, especially the EAX sounds missing.
     
  5. Goatman

    Goatman Ska Daddy

    Messages:
    676
    They seem to work well for me
     
  6. indyjones

    indyjones OSNN.net Adventurer

    Messages:
    1,567
    Location:
    England
    Has anybody had dvd playback problems with powerdvd and multispeaker mode with these?
     
  7. apu95

    apu95 Caffeine-->Code Converter

    Messages:
    502
    Location:
    Montreal, Canada
    dvd playback in powerdvd? nope....i watched the last samurai yesterday with DTS on and multispeaker on and it worked like a charm
    im guessing u didnt have this problem b4 upgrading right?
     
  8. indyjones

    indyjones OSNN.net Adventurer

    Messages:
    1,567
    Location:
    England
    sorry just changed them and its still doing it so its not these drivers. Have no idea whats doing it as I said its fine in 2 speaker mode but as soon as I change to 6.1 or 5.1 it messes up :(