networking with firewire

Discussion in 'Windows Desktop Systems' started by dubstar, Apr 23, 2004.

  1. dubstar

    dubstar format c:

    Messages:
    1,357
    Location:
    Southern California
    how would i set up a firewire network.. i've tried using the network setup, but it doesnt seem to work.

    my buddys notebook is using an amd64, and im using athlon xp, both using Windows XP 32bit edition.

    we cant get it to access the internet, let alone transfer files....

    help me obi wan, your my only hope.
     
  2. ming

    ming OSNN Advanced

    Messages:
    4,252
    Location:
    UK
    You can't set it up using the Wizard. You'll need to configure an IP manually for the firewire connections on both machines. Also, if you want internet sharing, just enable internet connection sharing in the connection properties.
     
  3. ming

    ming OSNN Advanced

    Messages:
    4,252
    Location:
    UK
    One other thing though. If you do use firewire for networking, be warned that it's not a secure method of sending data between two machines.
     
  4. dubstar

    dubstar format c:

    Messages:
    1,357
    Location:
    Southern California
    how would i establish an IP manually?

    btw: thanks for all the help.
     
  5. ming

    ming OSNN Advanced

    Messages:
    4,252
    Location:
    UK
    go to the view all connections in network connections (control panel), or if you see the connection icon for your firewire in system tray.
    then go into its properties>TCP/IP settings. Instead of allowing it to obtain an IP automatically, select the option below that, and set an IP of your own. Make sure that this IP will not conflict with your existing settings for other connections.
     
  6. ming

    ming OSNN Advanced

    Messages:
    4,252
    Location:
    UK
    argh.. I was reading on IEEE1394b (Firewire800) the other day and it had a little bit of info regarding home networking with it. Can't seem to find it now. :(
    It doesn't exactly tell you how to set one up, but I'm sure you would have found it quite interesting to read.
     
  7. ming

    ming OSNN Advanced

    Messages:
    4,252
    Location:
    UK
  8. ming

    ming OSNN Advanced

    Messages:
    4,252
    Location:
    UK
  9. dubstar

    dubstar format c:

    Messages:
    1,357
    Location:
    Southern California
    thanks
     
  10. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    How so?
     
  11. ming

    ming OSNN Advanced

    Messages:
    4,252
    Location:
    UK
    You'll have to read on the tomshardware article. It mentions the reason in there, and besides, Firewire was not intended to be used as a network device.
     
  12. dubstar

    dubstar format c:

    Messages:
    1,357
    Location:
    Southern California
    hm, i set the firewire to have its own IP addy, but i honestly couldn't even get it to connect the 2 pcs and share files... screw this, im getting a router.

    thanks for the help anyway Ming.
     
  13. ming

    ming OSNN Advanced

    Messages:
    4,252
    Location:
    UK
    That's weird. I've been having probs with my Firewire lately too. Not sure why. =(
    But I love it when it does work. Files fly across in seconds instead of minutes. :p
     
  14. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    go get a gigabit router and NIC cards, even faster :p
     
  15. ming

    ming OSNN Advanced

    Messages:
    4,252
    Location:
    UK
    So true!! will have one in my new machine. but routers dont support it though.
     
  16. ming

    ming OSNN Advanced

    Messages:
    4,252
    Location:
    UK
    Hey, I've finally had a chance to connect my laptop and PC together via firewire. They work, but only when I disable ethernet/wireless connections first.
    Also, regarding the manual setting of the IP, I used (for laptop) 192.168.20.1 (use the same IP for the gateway as well. Then on the PC, use exactly the same IP as the laptop, expect in the first box, change the last digit to a different number e.g. 192.168.20.2.
    This has worked for me, and as I mentioned, I had to disable ethernet/wireless connections before I could get firewire connection working properly.

    Another problem I discovered was trying to get back my wireless connection for my internet. I couldn't get it working until I disabled the firewire connection. I have no idea why this is, but at least now I know where the problem could lie when one of the two connections stop working when they are both enabled.
     
    dubstar likes this.
  17. dubstar

    dubstar format c:

    Messages:
    1,357
    Location:
    Southern California
    i appriciate the time you've put in.. it does work when i follow your steps, and im hoping somehow XP SP2 fixes it.

    thanks again.
     
  18. LeeJend

    LeeJend Moderator

    Messages:
    5,291
    Location:
    Fort Worth, TX
    I'll bet SP2 kills it completely. Any takers?
     
  19. ming

    ming OSNN Advanced

    Messages:
    4,252
    Location:
    UK
    Are you serious? Actually, I haven't even installed SP1 on my desktop to be honest. Not sure if I'm going to put SP2 on at this rate. :D
     
  20. crono_logical

    crono_logical Bird Eater

    I had no problems (other than my firewall configurations being overly restrictive and blocking the new IPs I picked for this network) to network a WinXP PC and WinXP SP1 laptop together over firewire. Both machines also have at least one NIC and both have ICS installed, and so I can also access the internet from either machine, regardless of which is plugged in, given appropriate gateway reconfiguration if I switch the machines over. I didn't need to disable any of the NICs either to get this to work, it worked straight off for me (after fixing my firewalls). I can also transfer files betwen the two machines at the max speed of my hard drives (I only have UDMA5 max on any internal drive on either machine), so this is clearly a nice configuration for me.

    For the manual IPs, I'm using 192.168.44.1 and .4 at the moment.