Networking Win98 and XP

Discussion in 'Windows Desktop Systems' started by Glaanieboy, Jan 9, 2005.

  1. Glaanieboy

    Glaanieboy Moderator

    Messages:
    2,626
    Location:
    The Netherlands
    I have 3 laptops and one desktop at home. The 3 laptops all have Windows 98 SE installed on them, while the desktop got XP (Pro) installed. These machines are all interconnected with a router + 4ports switch, they all have unique computer names and are connected to a single workgroup called thuisnet.lan. Attached is a table with OS'es, computernames and Firewalls.

    When I share folders on the network, I can read/move/delete/modify data from my XP machine to Windows 98 just fine, all works and with good speed. But when going from one of the 98 machines to XP, it always needs a password, when I enter the admin password of the XP machine, it doesn't accept it. I have setup McAfee to accept all IP's on my network as trusted and therefore should not apply firewall rules to it. I even disabled the firewall and it still doesn't work.

    How can I setup Windows XP to accept incoming requests for sharing files/folders/printers without asking for a password?
     

    Attached Files:

  2. Mubbers

    Mubbers Shoot! Political User

    Messages:
    1,087
    Cripes I had that between XP machines.

    Check the various WEP keys and try rebooting the machines in different sequences.

    With the three machines I had running recently the machine connected by ethernet to the router seemed "in control" of the rest.

    You might also want to check very carefully that if you have SP2 that windows security isn't firewalling you out :)
     
  3. Weasel

    Weasel Define 'Cynical'

    Messages:
    163
    Location:
    Sammamish, WA
    I believe if you enable the Guest account it should work. Or create the user Anonymous with no password and give them access to the directory you're trying to upload to.
     
  4. Glaanieboy

    Glaanieboy Moderator

    Messages:
    2,626
    Location:
    The Netherlands
    @Mubbers: My network is wired, not wireless, I forgot to say that. Also the Windows XP SP2 firewall is disabled and the McAfee firewall is told to trust all ip's within my network.

    @Weasel: That doesn't work. It still asks for a password. Enabling the guest account as well as creating a user called 'anonymous' doesn't work. BTW, I created anonymous and now I can't remove it, there just isn't an option to remove it. Do you know how I can remove it? Because I now have a user called anonymous with full privileges and no password.

    edit: I also created a user with the same name as the user on the 98 machine on my XP machine, that didn't work as well.
     
  5. Khayman

    Khayman I'm sorry Hal... Political User Folding Team

    Messages:
    5,518
    Location:
    England
    Run the networking wizard on the xp machine, i've had 98 networked to xp in the recent past with no problems, no need for createing new user accounts or other things.

    Also check the sharing properties of the folders you are accessing on the XP machine to make sure they are not set to require a password
     
  6. Glaanieboy

    Glaanieboy Moderator

    Messages:
    2,626
    Location:
    The Netherlands
    In Windows 98 you can browse to the network share, but everytime I click the + icon at the computername of the XP machine, it already asks for a password.

    I have never used the wizard before, but it seems the wizard can create a networking disk for autoconfiguring the rest of the machines. I just did this so let's see what happens.
     
  7. Glaanieboy

    Glaanieboy Moderator

    Messages:
    2,626
    Location:
    The Netherlands
    Despite running the wizard on both the XP and 98 machine (using the disk XP created), it still doesn't work :(
     
  8. Weasel

    Weasel Define 'Cynical'

    Messages:
    163
    Location:
    Sammamish, WA
    You can't delete it? That's odd... In win2k, if you make an anonymous account, win98 can connect, ahwell. Try going to Computer Management (right click on My Computer, select Manage) and go to Local Users and Groups and try to delete the account that way. If you can't, just disable it.
     
  9. Glaanieboy

    Glaanieboy Moderator

    Messages:
    2,626
    Location:
    The Netherlands
    Done that, anonymous is gone now. Thanks.
     
  10. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    Since you are using XP Pro, disable simple file sharing, then add a user account WITH password to the 98 PC's. Make sure that you also have that same username and password on the XP Pro box. Thats it, don't run the networking wizard, ever, it just screws things up.
     
  11. Glaanieboy

    Glaanieboy Moderator

    Messages:
    2,626
    Location:
    The Netherlands
    1) And how can I disable simple filesharing?
    2) I don't want to do that, I just want to have the 98 machines boot up to the desktop without having to worry about any usernames. Or can I set a password AND let the machines directly boot to the desktop?
    3) Will do.

    Will I run into the same problems if I decide to run XP Home instead of Pro?
     
  12. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    You might be able to get it to work with XP Pro and using anonymous access by this:

    Go to the Start Menu and click on Run. Type in gpedit.msc and click OK. Navigate to Computer Configuration / Windows Settings / Security Settings / Local Policies / Security Options. Now double click on Accounts: Limit local account use of blank passwords to console login only. Change this to Disabled and click OK.

    If that doesn't work, which I really don't know if it will, to disable Simple File Sharing, open up explorer, go to Tools > Folder Options, click on the View tab, scroll down, it is the last option.

    I don't think I've used XP Home in a network environment with 98. You can set the password automatically so it boots right to the desktop in Win98. http://www.winguides.com/registry/display.php/125/

    The reason the Networking Wizard is useless, is basically because it doesn't do anything. It likes to create network bridges that can screw up your network with firewire devices. Basically there is nothing to home networking, you pretty much plug the stuff in and it works.
     
  13. Glaanieboy

    Glaanieboy Moderator

    Messages:
    2,626
    Location:
    The Netherlands
    OK, I played with it some more and here's what I done:
    - I created a password for the user on the 98 machine; the autologon tweak did not work unfortunately. I might have made an error somewhere, I'll check that later
    - I created the same username/password combination on the XP machine, made it a member of the Guests group only.
    - Restarted the 98 machine and after logging in I could browse the XP machine just fine, no password sh1t. And of course I added the printer, it automagically installed the correct printerdrivers (I preinstalled them in some folder on the XP machine) and it worked fine :)

    Now there is one more thing:
    How can I hide the extra user I made on the XP machine from the users list in the Welcome screen? I have only made the user with the sole purpose of being able to network browse to the XP machine, nothing more, nothing less.

    edit: And thanks again j79zlr, as always :D
     
  14. JJB6486

    JJB6486 Retired Mod Political User

    Messages:
    1,207
    Location:
    West Lafayette, IN, USA
    Go into regedit, navigate to this key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\SpecialAccounts\UserList

    Create a new DWORD value, make its name the name of the user you want to hide from the Welcome Screen, and leave the value set to 0.

    -JJ
     
  15. Glaanieboy

    Glaanieboy Moderator

    Messages:
    2,626
    Location:
    The Netherlands
    Thanks JJ! :)