Mouse's back button is not working

Discussion in 'Windows Desktop Systems' started by Mazspeed, May 7, 2005.

  1. Mazspeed

    Mazspeed OSNN Addict

    Messages:
    85
    Location:
    Campbell Ca
    Ok I have a Logitech mouse that is not working correctly. It's one of the new optical ones with the scroll, and back button feature on the top of the mouse. Problem is that it doesn't work. My last Logitech mouse I had, had the same button, and did work, but this new one doesn't. I try and change my mouse properties and it seems broken as it just goes back to the normal default setting. I can't change anything, and I did load the disk, so now I'm confused on what to do.

    Thanks in advance
    Mike
     
  2. Jewelzz

    Jewelzz OSNN Godlike Veteran

    Messages:
    10,977
    Location:
    California
    Are the drivers up to date? (This coming from someone who just had driver problems :p )
     
  3. zeke_mo

    zeke_mo (value not set) Staff Member Political User Folding Team

    Messages:
    1,984
    Location:
    Placerville, CA
    I would uninstall the software that came with the mouse. Then it will default back to well....default settings. Unless you use the software for custom buttons, I would uninstall it.
     
  4. Mazspeed

    Mazspeed OSNN Addict

    Messages:
    85
    Location:
    Campbell Ca
    Hey guys, I did both :-(
    So far nothing has worked. It seems very odd.

    Mike
     
  5. zeke_mo

    zeke_mo (value not set) Staff Member Political User Folding Team

    Messages:
    1,984
    Location:
    Placerville, CA
    what mouse is it?
     
  6. Mazspeed

    Mazspeed OSNN Addict

    Messages:
    85
    Location:
    Campbell Ca
    It's the logitech Cordless click optical mouse. It's the $39 dollar model. My mouse settings are unable to be changed either. For some reason when you do change it, it goes right back to the default settings.
     
  7. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

    I kno for my Logitech Cordless Desktop LX 700 I had to set back to a ALT+Left ALT+Right in order for back and forward to work in firefox.
     
  8. 762x51

    762x51 168gr BTHP

    Messages:
    86
    Location:
    LI, NY
    On my MX1000 I needed to set the back button to a "generic button" in Setpoint. Firfox worked fine after that.