mounting issues..

Discussion in 'Linux & BSD' started by AcftMecH, Apr 12, 2005.

  1. AcftMecH

    AcftMecH OSNN Addict

    Messages:
    99
    hmmm... installed kubuntu 5.04...working good except a mounting issue...

    this is my FSTAB:

    proc /proc proc defaults 0 0
    /dev/hda2 / ext3 defaults,errors=remount-ro 0 1
    /dev/hda5 none swap sw 0 0
    /dev/hdc /media/cdrom0 udf,iso9660 ro,user,noauto 0 0
    /dev/hdd /media/cdrom1 udf,iso9660 ro,user,noauto 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
    /dev/hda1 /windows/C vfat defaults 0 0
    /dev/hda4 /windows/D vfat defaults 0 0


    I believe this is what I have done in other distros except it was hda5 for D drive, but the swap shows up as hda5 with this distro.

    C drive mounts fine.... D drive will mount after some playing (mount -a) but I get the following:

    mount: wrong fs type, bad option, bad superblock on /dev/hda4,
    missing codepage or other error
    (aren't you trying to mount an extended partition,
    instead of some logical partition inside?)
    In some cases useful info is found in syslog - try
    dmesg | tail or so


    then this...

    root@DeskLinux:/etc # dmesg | tail
    agpgart: Putting AGP V2 device at 0000:01:00.0 into 1x mode
    drivers/usb/input/hid-input.c: event field not found
    drivers/usb/input/hid-input.c: event field not found
    eth0: no IPv6 routers present
    FAT: bogus number of reserved sectors
    VFS: Can't find a valid FAT filesystem on dev hda4.
    FAT: bogus number of reserved sectors
    VFS: Can't find a valid FAT filesystem on dev hda4.
    FAT: bogus number of reserved sectors
    VFS: Can't find a valid FAT filesystem on dev hda4.


    any ideas?

    thanks
     
  2. you're trying to mount as vfat you're disk file system has to be fat32 or fat for that work, try using
    mount -t ntfs /dev/hda1 /mnt/blah
     
  3. AcftMecH

    AcftMecH OSNN Addict

    Messages:
    99

    UMMMM ... it is fat32...LOL

    it works if i use the command " mount -a" which remounts everything in the FSTAB. I just get the following message:

    mount: wrong fs type, bad option, bad superblock on /dev/hda4,
    missing codepage or other error
    (aren't you trying to mount an extended partition,
    instead of some logical partition inside?)
    In some cases useful info is found in syslog - try
    dmesg | tail or so

    But upon reboot it wont work.


    I am thinking that Ubuntu does some partion assigning differently then the likes of suse or mandrake. Although suse and mandrake auto setup your mounts, i am pretty sure that this same D Drive was HDA5 and with Ubuntu it is HDA4. i have tried every number... then it just wont find anything.

    any more thoughts?
     
  4. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    run fdisk -l as root and it will show your partitions. You can't have a hda4 without hda2 and hda3, hda5 would be an extended partition.
     
  5. karl_axe

    karl_axe OSNN Addict

    Messages:
    75
    ya there is definitely sumthin wrong. try 'rebuildfstab'. i did that in knoppix and it fixes the fstab. ubuntu is debian based and it may have similar features
     
  6. AcftMecH

    AcftMecH OSNN Addict

    Messages:
    99

    yeah, i have actually removed and installed several distros since then, but i am back using kubuntu on that machine (desktop) and Mandriva 2k5 on my lappy. it was wierd, only had problems with that distro, but not anymore. between setups, i rebuilt my entire partition table and it hasnt had a problem since then.

    thanks