Mandrake 9

Discussion in 'Linux & BSD' started by vdubVR6, Nov 23, 2002.

  1. vdubVR6

    vdubVR6 Guest

    Okay I have everything set up and installed, but can I have linux be on same "workgroup" network that I have set up for my windows PC's if so how?? and second how in the world are you supposed to get the divx codec!! every time I got to install(from divx) it works fine unitil its ready to ask to download(save or open) then I get a page full of letters and numbers that don't make sense!! PLEASE help!! if you can't tell I'm a n00b at this OS!!!:) thanks
     
  2. MadHaXX()|2

    MadHaXX()|2 Guest

    yea you can have them on the same workgroup.

    1) go to your programs menu and find something about services (maybe under system...) set the "smb" service on and start it (make sure that its checked off & saved so it starts up when linux starts).

    2) look under your program menu's for something about samba configuration. it has a web interface so setting it up should be pretty easy. set the workgroup to your windows worgroup and set the username/passwd to an existing account on your workgroup.

    after this you oughtta have a shared workgroup.

    the reason the you're getting garbled text (im assuming youre talking about the browser showing garbled text instead of downloading the prog) is because you need to set up your MIME types in the browser it's self, it has nothing to do with your os. by default the browser will treat everything as text. you need to set somthing like "application/x-binary" and download as the action it takes. BTW I'm guessing what the MIME type is, it's SOMETHING like that. i'll try to look up EXACTLY what it is (post what the file extention is... thats what determines what you have to set up your MIME type as). try downloading it with another browser or in windows (burn it onto disk then use it under linux)

    if you have a hyperlink you can always just right click on the link and choose "save link target as" and that ought to start a download.

    good luck
     
  3. vdubVR6

    vdubVR6 Guest

    Thanks MadHaXX()|2, it wasn't exactly as you said, but close enough I found what you were talking about. (networking, samba) But I'm still having trouble with DivX I d/l'd it and it was put in an "ark" I assumed that I was supposed to extract sense it had the choice, but that didn't work I could not install the "shell script" said it wasn't there even though I was clearly looking at it!! any advice....thanks again:)
     
  4. vdubVR6

    vdubVR6 Guest

    O one more thing is there a way to install real player or quicktime someone once told me that I would need some kind of windows emulater, how would I do this or go about getting it b/c I'm not sure?
     
  5. NetRyder

    NetRyder Tech Junkie Folding Team

    Messages:
    13,256
    Location:
    New York City
  6. SPeedY_B

    SPeedY_B I may actually be insane.

    Messages:
    15,800
    Location:
    Midlands, England
    Real Player has been ported to Linux, just go grab it from real.com
    Not sure about quicktime, wouldnt have thought apple would port that to linux, but as NetRyder says, check out WinE for emulation :)
     
  7. MadHaXX()|2

    MadHaXX()|2 Guest

    good job... i dont use windows myself, and have never set up samba before so that was a shot in the dark.... but it looks like you're more than capable of getting down and dirty in linux. good work

    hmm...never seen that type of file before, im guessing its an archive file of some sort. try typing this in the command line (make sure to be in the local directory that the file is in) "file name_of_file.ark" and it should be able to tell you what kind of file it is.

    try "chmod 755 filename.ark" replace filename for the name of the file. chmod 755 the_install_script also. it may be that it dosent have permission to execute...?

    if that fails we could alter the shell script to call the file explicitly. if you can try to pm me the script file and the name of the file that you downloaded (and its full path /.../.../filename.ark) i can take a look at it and try this.
     
  8. vdubVR6

    vdubVR6 Guest

    The name of the file that was downloaded was divx-player-installer.taz.gz
    when I go to open it says(in the heading) /home/vdub/Desktop/divx-player-installer.taz.gz
    and inside are 7 files and it has permissions size timestamp etc....but when I go to open one, it does nothing. the only option I have is to extract(i guess) so I do and still nothing happens when I click on the folder or the contents within?do I need to execute a command? And thanks NetRyder and SPeedY_B, I'm going to check that out now!
     
  9. MadHaXX()|2

    MadHaXX()|2 Guest

    did you do this:

    $ gunzip divx-player-installer.tar.gz
    $ tar -xvf divx-player-installer.tar

    is that a .tar.gz or taz.gz, ive never seen the taz ext. but tar is a archive file.
     
  10. vdubVR6

    vdubVR6 Guest

    Allright guys, sorry it took long to reply but holidays you know.So to answer you MadHaXX()|2 yes the file was a .tar extension but none of the commands worked. I think its just not a good file, I'm going to re d/l from divx and see if that helpls.

    $ gunzip divx-player-installer.tar.gz
    $ tar -xvf divx-player-installer.tar

    but I did get wine installed but it keeps asking for a "xmessenger"when I go to run the app. I did some searching on google/rpm.net for an rpm for it with no luck,turns out other people have had the same problem. I found a gxmessenger but that didn't work, and I tried the allias xmessenger=gxmessenger(maybe I did it wrong) command but that didn't work either. do you know somewhere I could get the right download for the xmessenger for mandrake 9.0. Thank you again for all your help.


    :D
     
  11. MadHaXX()|2

    MadHaXX()|2 Guest

    what are you running in wine? I've never seen that before. it may be that the program youre running has a dependency on a program (internal maybe) called xmessenger. i couldnt find anything on that either which makes me think that its internal in the emulated prog its self.

    did you do a [you do kow that the "$" is the prompt symbol, you dont type that?]

    $ wine --configure

    before you tried to use it? to set up the wine profile?
     
  12. vdubVR6

    vdubVR6 Guest

    LOL, yeah I made sure to take out the $ b4 using the command, I believe that the file is bad because it keeps giving me a DivX error, not a Linux error. As for the --config, yeah I went through that whole set up. Made my other partition part of wine, but I can't even launch wine itself ie. "winelaunch" or even "notepad wine" I get an error saying that "wine" needs xmessenger to operate successfully. And that I needed to install xmessenger in order to use wine. I'm getting ready to run it now and see what happens. I also saw a contrib file on codeweavers so I'm going to see if that helps!
     
  13. MadHaXX()|2

    MadHaXX()|2 Guest

    did you download it & reinstall it from the winehq.org website? it might have already been there from the standard install. if you did, was it source that you rebuilt or an rpm binary that was installed? sounds like you need to fix wine (reinstall it or something).
     
  14. vdubVR6

    vdubVR6 Guest

    this is a post off of another website that I found for trying to troubleshoot I don't want to post a link to that forum(guidlines you know)so I'll just put what they had to say.

    -1) oh yeah, the wine i downloaded was the newest codeweavers wine version. The only prob I have is that it displays an error in the console about not being able to find xmessage which "wine relies on heavily" I know that when I type gmessage in the console, it displays the line xmessage [something] [application]. SO is gmessage Mandrake's version of xmessage?

    -2) I used that wine version. Installed it using their automated installer (just follow the stuff on the page).
    After installation, it should just work. Oh yeah, if you have drake then there's a little problem, you won't have xmessage, which Wine needs.

    -3) Drake renamed xmessage to gmessage. so you have to do this:
    in command, su root,
    ln -s /usr/X11R6/bin/gmessage /usr/X11R6/bin/xmessage

    That should do it for ya.


    Don't know if that helps any, I'm still trying to find xmessage for drake. untill then I'm using desktop l/x (which is not as nice as drake IMO) and as you saw in my other post l/x doesn't read PERL files but I'm gonna try what you recomended! and THANK YOU you have been a lot of help!!!! :D