LPT1 and Code 12 issues

Discussion in 'General Hardware' started by abakken, Dec 28, 2005.

  1. abakken

    abakken OSNN One Post Wonder

    Messages:
    3
    I need some help with a printing problem. I am not a techie but my wife thinks I can fix the computer. Please help me gain favor in her eyes!

    Yesterday our printer would not print - got an error message. Followed the troubleshooting guide all the way to the Device Manager. Turns out I ahve a few new issues. LPT1 has a Code 12 issue with the Com1 and Com2 ports. The disputed resources are:
    I/O FFFF-10006 and FFFF-10002

    I tried to uninstall the Com ports but on restart they came back (plug and play) as Com4 and 5 with the same issues. I unplugged the ptinter cable from the computer, restarted, same issues.

    I tried to change the resource allocation on the LPT1 to Basic000
    I/O 0378-037F 0778-077B
    IRQ 03
    DMA 00

    upon restart, there was no longer a Code 12 error (or any other error ) with LPT1 but still nothing would print. No errors just nothing at all.

    Details> running XP, hardware includes the Epson printer with an older Paperport scanner pigtailed to it (scanner has an error when I try to use it also), a CD-RW, a DVD-RW, and the 3.5" floppy drive. I recently swapped the monitor with a new flat LCD but printed and scanned after the change. Recently upgraded to Norton Anti-virus 2006 but printed after installation.

    Side Note: I also have a code 10 on the floppy drive and uninstalling and reinstalling did not solve.

    Obviously I need help in getting the printer to work again. Also I am very curious as to how I could have this problem when I have not added any new hardware to the system. Can a virus cause this? I have Norton and Microsofts AV, anti-spy, firewalls all running.

    Any help would be greatly appreciated. It is great that theere are people like you out there to help people like me.

    Thanks,
    Andy
     
  2. Steevo

    Steevo Spammer representing. Political User Folding Team

    Messages:
    2,566
    You seem to have a BIOS configuration problem. Is this a computer that used to be running 9X or ME?
     
  3. abakken

    abakken OSNN One Post Wonder

    Messages:
    3
    This computer (eMachine) is about a 1 year old and came with XP already on it. The only thing I have done hardware wise is take out the internal DVD-ROM and replace it with a DVD+-RW. That was 8 months ago.

    Andy
     
  4. LeeJend

    LeeJend Moderator

    Messages:
    5,291
    Location:
    Fort Worth, TX
    Now that you have the HW conflict fixed try uninstalling and then reinstalling the printer and scanner. Go to device manager and select uninstall for each device then reboot. Make sure you have your install CD's handy. Printers and scanners often will need extra files Windows does not have in it's library. The uninstall will force windows to reinstall the device drivers which should pick up the new I/O configuration.

    As for why Windows does these things - too much fancy crap and bloatware at the sacrifice of basic functionality, stability and security.

    It could have been a mis-behaved application, a security update that corrupted and unrelated function. Possibly malware, but probably not.

    So to be safe make sure your anti-virus is up to date and download and run spybotsearch and destroy and adaware. You will probably get hundreds of hits on the spyware scan but most should be harmless.

    If you don't have an antivirus, sahme on you! Download AVG antivirus. There is a free version that will update daily.
     
  5. Mastershakes

    Mastershakes Moderator

    Messages:
    1,721
    Location:
    Montreal
    Care to expand on that? Back it up?

    I really don't understand this statement at all. In 3 years my XP has run clean and fast. With the bells and whistles turned on or off. It's never been compromised either.

    I'm real tired of reading baseless statements. /rant done.
     
  6. abakken

    abakken OSNN One Post Wonder

    Messages:
    3
    You all got a little off topic there - but that is probably a moot point. Last night the power supply and motherboard went so now I have a nice collection of parts. Looks like I am going shopping for a new computer tonight.

    Anyway, thanks for looking at my post - sorry it ended up being pointless.

    A