Low on virtual memory

Discussion in 'Windows Desktop Systems' started by Shooter1973, Aug 20, 2002.

  1. Shooter1973

    Shooter1973 Guest

    For a little while now, I've been receiving a low on virtual memory message when I go to shutdown out of Win XP. I have 196 mb, any suggestions?
     
  2. Shooter1973

    Shooter1973 Guest

    ya that's set correct, and still the low virtual memory message.
     
  3. Shooter1973

    Shooter1973 Guest

    So if I have 192 mb, you're saying 192 x 1.5 = 288 PLUS 384 = 672 for the initial size?
    so INTIAL SIZE = 672
    MAXIMUM = ????
     
  4. Shooter1973

    Shooter1973 Guest

    Thanks,
    What about the Maximum?
    Where'd you come up with this?
     
  5. allan

    allan Guest

    What you want to do is go to System Properties - Advanced - Startup & Recovery Options and where it says Write Debugging Information change the setting to NONE. Then reboot and you should never see that message again.

    As for the above suggestions about changing your pagefile settings, if you have them at 1.5x you'll be fine.
     
  6. Perris Calderon

    Perris Calderon Moderator Staff Member Political User

    Messages:
    12,332
    Location:
    new york
    Allans post is a good one...

    hardly anyone ever uses the information written in a memory dump...

    just so you're informed, if you do have a problem, this information won't be available to evaluate...wwhich hardly anyone can evaluate anyway

    if you can resolve your problem by increasing your pf, as catch suggests, no harm there either way...that's probably your best choice

    ...make sure you defrag the pf with the free pf defrag proggy I posted on the great free programs thread...once you increase the size, the pf will be fragmented, but onc you defrag it, it should never be fragmented again...less you increase the size again
     
  7. Shooter1973

    Shooter1973 Guest

    Weird, after Allan's tip i thought for sure it would be better, but still getting it.
    Dealer> What page is that program on in that link?
     
  8. Sancho

    Sancho Guest

    I heard that you should set both to 3X the amount of ram you have. This is so windows does not have to resize the paging file, and thus eat performance.

    Flame me if I'm wrong, but it works well for me.
     
  9. allan

    allan Guest

    shooter - what's the exact message you are getting please?
     
  10. Perris Calderon

    Perris Calderon Moderator Staff Member Political User

    Messages:
    12,332
    Location:
    new york
    shooter...allan will be able to help you best with this problem...try what he gives you;

    here is the pf defrag program...excellant

    sancho, if the pf wants to expand, it's because the comit charge has reached the comit limit...if this is so, then the pagefile is too small...in other words, if the os wants to expand the pf, your performance will be enhaced, not deminished by allowing it to expand.

    it also means your initial minimum is too small, and needs to be increased...but restricting the expansion when the os wants to expand will hinder performance
     
  11. Shooter1973

    Shooter1973 Guest

    "your system is low on virtual memory. windows is increasing the size of your virtual memory paging file"
     
  12. allan

    allan Guest

    Okay, please take a look at your pagefile settings and see what they say. Then look and see if you actually have a file named pagefile.sys in the root of the drive where the pagefile is set. This could be one of several things, but first lets make sure your system is actually creating the pagefile.

    Also, is your pagefile on the boot drive?
     
  13. Perris Calderon

    Perris Calderon Moderator Staff Member Political User

    Messages:
    12,332
    Location:
    new york
    you should unhide system folders to get it in your search

    windows key+e>tools>folder options>view
     
  14. Shooter1973

    Shooter1973 Guest

    ya it doesn't seem to be there
     
  15. allan

    allan Guest

    Yeah, I was afraid of that. It seems that on some systems XP for some reason does not create the pagefile. I'd suggest trying the following (though it may or may not work):

    Change your pagefile settings to NONE on all drives and reboot. Reboot again. Now go in and create a pagefile on the boot drive. Reboot. Now see if there is a pagefile.sys on your c: drive (or whatever your boot drive is). If so, you should be okay now. If not, you may have to do a reinstall.

    I've never seen a fix for this other than a reinstallation.
     
  16. Perris Calderon

    Perris Calderon Moderator Staff Member Political User

    Messages:
    12,332
    Location:
    new york
    shooter...after you've tried what allan suggests, but before you do a reformat, I'd like you to download coolmon.

    Someone in my office also cannot locate the pf, but coolmon says it's there, at the value that we set it to...this is very interesting to me.

    he however does not get the low on virtual memory message...anyway, download coolmon, and we'll take a look
     
  17. Shooter1973

    Shooter1973 Guest

    allan> i made a pagefile.sys from a txt file is this correct? i did what you said & then reset it to let the system manage it. i'll let you know what happens.

    dealer> i installed coolmon, but not sure what i'm looking for.
     
  18. Perris Calderon

    Perris Calderon Moderator Staff Member Political User

    Messages:
    12,332
    Location:
    new york
    first, configure your coolmon...if you don't know how, go here

    now, put the pf in the monitor

    right click the coolmon icon that's in your system tray;

    hit displayed items...then in the tree on the left, you should see page total, and page used.

    double click on those, and push apply

    if you want both of these values on the same line, paste the following in the tree on the right;

    page used: <NAME=PageUsed>/PageTotal: <NAME=PageTotal>
    now coolmon will demonstrate the pf

    we are then going to manually resize your pf, and see if coolmon recognizes the new size you create
     
  19. allan

    allan Guest

    shooter - no - you cannot just create a pagefile.sys from a text file. Sorry - I assumed you knew how to enable your pagefile.

    Go to System properties - Advanced - Performance - Advanced (again) - Virtual Memory Change button. Then follow the above advice for deleting and creating your pagefile. If you still aren't sure how to do this let me know and I or someone else will walk you through it.
     
  20. 2z

    2z OSNN Gamer

    Messages:
    2,439
    Location:
    England
    Shooter

    It could be a software conflict ???
    (Norton Live Update has been known to cause this problem)
    try this
    Start / Run " MSCONFIG "
    Hit the Startup tab
    Hit Disable All button
    Reboot
    If this fixes the problem
    go through the startup items and select them one at a time rebooting each time - this should help you to find which program is causing the conflict.
    ;)