Linux mouse problem

Discussion in 'Linux & BSD' started by Unleashed, Jul 26, 2003.

  1. Hi all, Im a fair old newbie to Linux and all its workings, but since I upgraded my computer Ive had this problem :(
    Ive tried all of these distros of Linux, but every one has had the same problem:

    Redhat 9.0
    FreeBSD 4.8
    College Linux 2.3
    Lycoris build_46
    Mandrake 9.1
    Slackware 9.0
    Debian 3.0r1

    The problem is as follows:

    During the installation of Linux (whichever distro) all appears to work fine, but as soon I as log into any GUI, the mouse doesnt work. There is no response from it. Ive tried using a basic 2 button PS/2 mouse, even reverted to an old Serial mouse, but nothing. My normal one is a Hewlett Packard optical USB.

    If anyone has any information about why this is, or how to fix it, I would be most grateful :D

    My hardware specs are my signature, so no need to retype :)
  2. Geffy

    Geffy Moderator Folding Team

    United Kingdom
    in FreeBSD you have to start the mouse daemon through /stand/sysinstall and then in the configuration section.
    The other ones I dont know but from what I remember with Linux you commonly need to choose the mouse you are using (Microsoft Mouse as the option usually works)

    Have you looked in your XFree86 config and checked that the mouse is correctly setup?

    BTW FreeBSD is Unix no Linux, being the FreeBSD nut that I am I just want to point that out ;)
  3. My mistake about FreeBSD :eek: Its just that its on :)

    Anyway, yeah I did what I could, but as I said Im new to Linux, and dont yet really understand all that sort of stuff. I think I'll employ Leon (mate of mine who seems to know what he's doing) to fix it for me, but when I described it he didnt really know what was wrong.
  4. Geffy

    Geffy Moderator Folding Team

    United Kingdom
    lol np ;)

    it is weird that the mouse doesnt work though, I dont think its cause its optical or anything like that cause my optical wireless one works just fine.
  5. Ive tried multiple mice :(
    Maybe my botherboard? Or some incompatibility between hardware? Just an idea :S
  6. dav3st

    dav3st OSNN Addict

    I had to load 2 modules, mousedev and usbmouse
    You can load the modules with the command modprobe
    modprobe mousedev
    modprobe usbmouse

    Hope this helps
    Sorry for my english
  7. Thanks for the idea, I'll give it a go. Going to reinstall RedHat 9 next week, see what happens :D
  8. Woohoo! I reinstalled Redhat 9, today with new ISO's I got, all works perfectly :D
  9. okguy

    okguy OSNN One Post Wonder

    I got nearly the same problem.
    When I install RedHat 7.3, the installation is OK, but the graphics interface does not work.
    How to use modprob to get a good installation ???
  10. j79zlr

    j79zlr Glaanies script monkey Political User

    modprobe loads modules into the kernel. It has nothing to do with the installation. You'd probably be better off starting a new thread on this, not posting in someone elses. Why are you installing a version of Redhat that is ancient?