News KeePass 1.17

Discussion in 'Windows Applications' started by American Zombie, Jan 23, 2010.

  1. American Zombie

    American Zombie Moderator Staff Member Political User

    Messages:
    2,934
    Location:
    Seattle
    Changes from 1.16 to 1.17:

    Added option to use file transactions when writing databases (enabled by default; writing to a temporary file and replacing the actual file afterwards avoids data loss when KeePass is prevented from saving the database completely).

    Added high DPI support.

    The Ctrl+E shortcut key now jumps to the quick search box.

    In the main entry list, backup entries are now rendered with green text color.

    Menus are now rendered with gradient item backgrounds.

    Added support for detecting KeePass 2.08 and higher KDBX database files.

    Added {GOOGLECHROME} placeholder, which is replaced by the executable path of Google Chrome, if installed.

    Added '--auto-type' command line option.

    Added '--lock-all' and '--unlock-all' command line options to lock/unlock the workspaces of all other KeePass instances.

    Added 'KeeConfigFileOverrideGlobal' and 'KeeConfigFileOverrideUser' configuration options to change the locations of the configuration files.

    On Windows 7, KeePass now shows a 'locked' overlay icon on the taskbar button when the database is locked.

    On Windows 7, when opening/saving a database, the taskbar button is now animated using an indeterminate progress bar.

    This was released in December but with the holidays I forgot to post it. :dead:

    :software: Download: KeePass 1.17
    :source: Source: KeePass Homepage
     
    Last edited: Jan 23, 2010
  2. Bman

    Bman OSNN Veteran Original

    Messages:
    8,799
    Location:
    Ottawa, Ontario
    Nice, love this program. But it's at version 2.0 or so...so...
     
  3. American Zombie

    American Zombie Moderator Staff Member Political User

    Messages:
    2,934
    Location:
    Seattle
    There are two different versions.
    Classic is at 1.17 while the pro is at 2.09 and requires at least 2.0 .NET framework.
    Some people do not want .NET framework or require the adanced features of 2.0x version.

    Editions Compared