Issue w/ other computers connecting to me through workgroup

Discussion in 'Windows Desktop Systems' started by Punkrulz, Sep 26, 2004.

  1. Punkrulz

    Punkrulz Somewhat eXPerienced

    Messages:
    790
    Location:
    Woodbury, NJ
    Hey guys,

    Was over my friend's house the other night with three computers [one being mine] networked together. People would not be able to see me through the workgroups what so ever. Whenever they would try connecting to my computer, \\DAN, they would get the following error:

    [​IMG]

    This error would occur both on the same workgroup, and in seperate work groups. I could connect to them with absolutely no problem at all. I was working with cpugenius, and we were troubleshooting the issue but have not come to a conclusion as to what this would be caused by. Some seem to think that it's caused by SP2 being installed on my computer, where as the other two only had SP1 [all running XP Pro]. I've been looking around and having seen too many resolutions. Has anyone encountered this before, and if so have you found a fix for it? My computer specs are in my signature.

    Thanks,
    Punkrulz
     
  2. emeritus

    emeritus Beware the Monkeys!!!

    Messages:
    326
    Location:
    Oakdale, CT
    Double check the IP addresses of all the systems. They should all have the same first 3 numbers e.g. 192.168.0, and the last number counts down each system. In your case 1, 2 & 3.
     
  3. Petros

    Petros Thief IV

    Messages:
    3,038
    Location:
    Pacific Northwest
    Try turning off everyone's software firewalls and try to connect again. Sometimes people block things that they might need.
     
  4. ming

    ming OSNN Advanced

    Messages:
    4,252
    Location:
    UK
    Yep, probably you set your own firewall to block access to your folders from other machines.
     
  5. Mainframeguy

    Mainframeguy Debiant by way of Ubuntu Folding Team

    Messages:
    3,763
    Location:
    London, UK
    HMMMMmm I doubt Punk did that (the firewall thing) - but am going to subscribe to this thread because I had similar issues recently (worked around them with shared folder) I am curious if it could be anything with SP2....
     
  6. Punkrulz

    Punkrulz Somewhat eXPerienced

    Messages:
    790
    Location:
    Woodbury, NJ
    All IP Addresses are the same. Mine was statically assigned, the other two were dynamic. No IP Address conflicts. By IP addresses being the same, I mean 192.168.1.*.

    Everyone's firewalls were off. No one had anything blocked that would be preventing them from being unable to communicate with me. They were able to communicate with each other, but both could not communicate with me.

    We have verified several times that I am in fact not running any software firewalls. There is nothing on my computer [that is known] that would be blocking other people from connecting to my computer.
     
  7. Mainframeguy

    Mainframeguy Debiant by way of Ubuntu Folding Team

    Messages:
    3,763
    Location:
    London, UK
    Did you grant a share on your root? Could they ping you?

    Just a couple of questions to try to help shake this down (me needs sleep now!)....
     
  8. Punkrulz

    Punkrulz Somewhat eXPerienced

    Messages:
    790
    Location:
    Woodbury, NJ
    I had a folder shared on My Documents, called VirtualCDs. Whenever I would browse through the network, I could see my own folders being displayed as shared.

    I don't remember if they were able to ping me or not, I'm pretty sure they were. I will be testing that soon when I'm on my sister's computer, as I'm having the same problem when I'm on hers and I get that error message... she's still running SP1.

    Oh, and Ming, I sort of took your signature. ;) I already had the specs listed in that format, I just added the color and words though for the specific components. :)

    Edit: Checked with my friends, they were able to ping my computer no problem.
     
  9. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

    What bout user permissions? Since its another user trying to conect it may be denying access. Try setting up the same username on your comp.
     
  10. Mok

    Mok OSNN One Post Wonder

    Messages:
    1
    I've had this problem several times before. To fix:

    Assuming you're using Windows XP Professional, go to Start->Run->gpedit.msc

    This will bring up the group policy management window. Navigate to Computer Configuration->Windows Settings->Security Settings->Local Policies->User Rights Assignment. Once here, check the two policies: "Access this computer from the network" and "Deny access to this computer from the network." Make sure "everyone" and "guest" are listed in the "access", and that neither are listed in the "deny."

    This should allow everyone to connect to your computer without a problem and view your shares. However, they may experience problems when trying to access shares. To fix this, disable simple file sharing by opening any folder on your computer and going to Tools->Folder Options->Advanced and unchecking "use simple file sharing (recommended)" near the bottom. Once you do this, right click on each of your shares and go to the security tab. Make sure "everyone" and "guest" are listed, and then click "advanced." Check the box that says "replace permission entries on all child..." then apply the changes. When prompted for "this folder only" or "this folder and all subfolders, files" choose the "all subfolders" option. Other users should now be able to access your shares without incident.

    --
    Mok
     
    Mainframeguy likes this.
  11. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    You also have to use passwords when connecting to XP Pro.
     
  12. Johnny

    Johnny .. Commodore .. Political User

    Messages:
    5,015
    Location:
    Happy Valley
    Are you using Zone Alarm ??? if you are uninstall it. Or what you could do is go into the zones and add each of the pc's ip's to the trusted zones. Turn off the internal firewall in the OS ..

    I had the exact same issue. When I unstalled zone alarm it worked. When I reinstalled zone alarm I had to add each network pc's ip to the trusted zone. If you use some thing like mcafee personal firewall you can have the program automatically set it up for you.
     
  13. Punkrulz

    Punkrulz Somewhat eXPerienced

    Messages:
    790
    Location:
    Woodbury, NJ
    Naw, we checked the user permissions over and over. The appropriate names had the appropriate permissions to be able to view the computer contents what so ever.

    You mean when like logging in, or what? I use a password to login to my machine, but that's about it...

    Johnny, if you would have read 6 posts up...

    I am NOT using any firewalls what so ever.

    LOW AND BEHOLD!

    Mok, you are a god in my eyes right now. That fixed the problem!!! Under the "Deny access to this computer from the network" portion, the account "Guest" was in there. I deleted it, went over to my sister's computer, and was able to connect to my computer fine!!! I am in debted to you, you saved me on that one. Good call!!!

    Just out of curiousity though, what specifically does Simple File Sharing do?
     
  14. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    Simple file sharing basically makes network shares insecure because it allows all users access via the Guest account, and if their permissions are not set correctly they can delete everything. It is a "feature" of the crippled networking available in XP Home.