Internet Connectivity Evaluation Tool for Windows XP/Vista

Discussion in 'Windows Desktop Systems' started by kcnychief, Mar 29, 2007.

  1. kcnychief

    kcnychief █▄█ ▀█▄ █ Political User Folding Team

    Messages:
    16,948
    Location:
    Massachusetts
    Source: http://www.hive.net/Member/blogs/th...28/Internet-Connectivity-Evaluation-Tool.aspx

    More info & Try it: http://www.microsoft.com/windows/using/tools/igd/default.mspx

    -edit-

    No surprise, but my RVS4000 passed with flying colors :)
     
    Last edited: Mar 29, 2007
  2. Vanquished

    Vanquished Mr. Bananagrabber Political User

    Messages:
    4,868
    Location:
    Massachusetts
    Later today.
    I am so gonna download this.
    Just to test my connection, although i have already done live meeting, but whatever :p
    Thanks
     
  3. madmatt

    madmatt Bow Down to the King Political User

    Messages:
    13,312
    Location:
    New York
  4. ray_gillespie

    ray_gillespie Moderator Staff Member Political User

    Messages:
    1,692
    Location:
    Birmingham, UK
    hey nice find. Everything works fine except uPnP. I get this shhit:

    The operating system is Windows Vista
    The firewall is enabled
    Exceptions are allowed by the firewall
    UPnP is enabled by the firewall
    UPnP services are running
    UPnP Discovery is enabled
    Detecting Internet Gateway Devices on the network
    1 IGD(s) found
    IGD Device Information:
    Manufacturer Name : Netgear
    Model Name : ADSL Firewall Router
    Model Number : DG834
    get_StaticPortMappingCollection() returned NULL IStaticPortMappingCollection
    get_StaticPortMappingCollection() returned NULL IStaticPortMappingCollection
    get_StaticPortMappingCollection() returned NULL IStaticPortMappingCollection
    Failed to get port mapping from the IGD


    Anyone got any ideas what I can do to fix this?
     
  5. LeeJend

    LeeJend Moderator

    Messages:
    5,291
    Location:
    Fort Worth, TX
    There's always the "check for router firmware updates".

    I'm having UPNP test problems too even though my router says it supports it. I'll post back if I find a solution.

    Got mine working :) but the test failed :( because it tries to create 10 new port mappings and my ancient linksys befsr11 only supports 5 remappable ports.

    Look through your options on your router setup. Mine was defaulted to uPnP turned OFF. I turned it ON and then went to the Port Forwarding page which had a uPnP screen button. My uPnP screen showed 10 pre-mapped items (SMTP, TCP, etc) and 5 re-mappable. I had to assign internal IP addresses to the premapped ones and enable each one for them to work.

    Hope that helps.
     
    Last edited: Mar 29, 2007
  6. Vanquished

    Vanquished Mr. Bananagrabber Political User

    Messages:
    4,868
    Location:
    Massachusetts
    Ok lol.
    Says that TCP not work, and UpNp...
    But thats complete BS... since all the vista features work lol :p
    Live meeting, and all the internet crap, including that find solution thing.
    Oh well. :p