Incomplete XP installation

Discussion in 'Windows Desktop Systems' started by Mike Jacoubowsk, Jan 13, 2002.

  1. I've got an ailing XP upgrade that's limping along due to an incomplete install. Here's what happens-

    Regardless of where you do a "repair" or a reinstall, everything goes fine until the final part where it's apparently copying files that are customized to your particular installation. The sequence, as shown on the screen, is-

    Installing windows
    Installing devices
    Performing configuration
    Copying files <== trouble area
    Registering components
    etc

    Copying files is where it bombs. It tries to copy admprox.dl_ from the temp directory it creates, and says it can't find it. The directory that it's pointing to *is* the correct one; "browse" and it's right there under you nose. I tried pointing it to the I386 directory on the CD, same thing happened. Gives you the retry etc box, and no amount of retrying makes a difference. Even tried copying the entire I386 directory to the C: drive and running the install entirely from there. Same darned thing. Every time.

    There are actually two sets of files it bombs out on. The first is the admprox.dl_ series, the second set starts with icwconnl.ex_. In both cases, if you tell setup you do not want to continue, it moves on. If you tell it you do want to continue, you'll go through the same issue (files that can't be copied) for maybe 50+ files each time.

    I've tried slowing the system down, removing & unplugging everything etc. Particulars of the system include-

    MSI 6330 AMD 1800 motherboard/cpu
    1 Gig Mushkin ram (tried with all manner of different ram, different
    amounts, same results)
    120 gig WD drive, with XP installing onto a 31.8 gig partition
    Geforce 2 video card

    As mentioned, the machine boots up fine and generally runs, but help files aren't available, certain OS functions simply don't exist. msconfig, for example, and some networking features) and there seems to be a problem resolving internet sites such that it takes a very long time to bring up a website, while other computers hooked up to the same DSL router bring them up instantly. No problem with email & newsgroups.

    Any ideas appreciated! Thanks-
     
  2. Lonman

    Lonman Bleh!

    Messages:
    2,642
    Is this a retail copy of XP? It sounds like you might have a bad CD.

    What did you upgrade from? Have you tried a clean install?
     
  3. Yes, it's a retail (upgrade) copy of XP. I doubt the disk is at fault, since I can copy the directories to the HD, and there's no problem manually expanding any of the files.
     
  4. Lonman

    Lonman Bleh!

    Messages:
    2,642
    Have you tried to do a clean installation?
     
  5. Lonman

    Lonman Bleh!

    Messages:
    2,642
    I'm at the MSI site now trying to find out more on your m/b, there are like 5 of them with the 6330 model name, which one is yours? Here's a pic of what i found:
     
  6. Actually, it's a K7T Turbo-R LE, found on this page-
    http://www.msi.com.tw/products/mainboard/mainboard.php?model=K7T+Turbo+Limited

    I've ruled out the network card by switchting that out last night.

    Think it would make sense to convert drive C: to NTFS and see if that makes any difference? Only reason I'm thinking of that is because it supposedly has *something* to do with the way it's dealing with files...
     
  7. Lonman

    Lonman Bleh!

    Messages:
    2,642
    The type of file system really shouldn't prevent the setup from going through.

    How do you have your hard drive set-up? Is it on your raid controller? During installation, when it asks to press F6 to install the drivers for the controller, is that completing properly? Is your bios set to boot to the raid?

    Have you been to the promise website to see if there are any compatiblity issues between your controller and hard drive? Also look for the latest drivers, I think the newest ones address some kind of XP issue. Heres a link to the promise site: www.promise.com.

    I just went to the page you provided for your motherboard. Have you updated it's bios? I found this under one of it's bios revision notes: Fixed problem wherein system cannot install WinXP when using other K7T series board except K7T Turbo2. Maybe it's your board? If you haven't flashed your bios yet... it could be that simple.
     
  8. All good ideas, but...

    I already tried installing with the "extra" (RAID) controller disabled.

    I also just tried reinstalling with the zip drive disconnected, since there have apparently been some issues with IDE zip drives. Still no luck.

    I think I'll try a clean install on an extra drive I've got and see what that does.
     
  9. Lonman

    Lonman Bleh!

    Messages:
    2,642
    It's the dissemination of information that aides to troubleshoot these kinds of problems. I asked some very clear questions and you didn't provide an answer to any of them. I apologize for sounding curt, BUT I am trying to help you to get XP set up on your system and there is a methodology to troubleshooting... a 'Sherlock Holmes' approach... eliminating suspects one at a time. In this case the primary suspect is your motherboard. I've taken the time to find some potential fixes, please take the time to at least answer the questions.
    This is a major feature, probably the reason you bought the board, it's also the second suspect.
    Go for it... it will provide a clue whether or not your new hard drive is a suspect or not, BUT, I would flash your bios if you haven't done so because apparantly there is a known issue with your board (and a fix available).
     
  10. Sorry, I wasn't trying to sound snide.

    I flashed my BIOS to the latest (3.3) just the other day. I also checked out the Promise website as you suggested, but nothing relevant I could find there, aside from an updated driver that might help (although logically, if I disabled the controller entirely and the problem was still there, I don't think it's going to make a difference, but I sure hope I'm wrong!!!).

    For what it's worth, I didn't buy the board for the RAID feature, but rather a reputation for reliability. Aside from this XP issue, it *has* been a remarkably bomb-proof board.

    One other possibliity is remnants from a prior Win2000 install in a different directory (but same partition).

    Thanks for the ideas-
     
  11. Lonman

    Lonman Bleh!

    Messages:
    2,642
    Cool. I'd suggest setting up your hard drive on the primary raid channel, formatting the primary partition, run an fdisk /mbr on it, and try a clean installation using the newest promise driver.

    I believe it's important how you have your hard drive ribboned too... if it's the master, i think it has to be attached to the black end of the ribbon cable. If it's the slave, i think it's supposed to be on the grey connector. And of course blue to blue on your m/b. Check your m/b manual to make sure. Good luck, I hope it goes through ok with the new driver.