Ie6 and Java Pop-ups

Discussion in 'Web Design & Coding' started by Barra, Mar 14, 2002.

  1. Barra

    Barra Guest

    I've read some posts relating to a similar problem but mine seems specifically related to pop-up windows that are generated by a Java script. The New window appears but is blank and then I get an error message and IE6 closes down.
    It has only been happening for a couple of weeks and may also be related to something I downloaded from Microsoft.(Not sure)

    I have applied some solutions provided by this forum relating to url's not opening in new windows etc but thus far nothing has worked.

    Any advice would be appreciated.

    (My solution atm is to Use Netscape on sites I know IE6 will crash on.)


  2. krisatkins

    krisatkins Guest

    I know this may sound silly, but have you tried re-installing your Java Virtual Machine. If not, try downloading the package from microsoft rather than lettting IE6 install it. That way you can do a re-install if it get damaged by the updates.
    Hope this helps
  3. Barra

    Barra Guest


    Thanks for your assistance but I had already installed the Microsoft VM again just last week.


  4. Lactic.Acid

    Lactic.Acid Guest

    Download and install Sun's Java VM from and make sure you install the IE plugin.
  5. Shamus MacNoob

    Shamus MacNoob Moderator Political User

    L'Ile Perrot Quebec
    sun java

    Yes I use the sun java plugin but I found something weird I use the 1.3.1_01 and everything is fine if I upgrade that to the newer version I cant play yahoo games now maybe its me and my set up but just in case I would like to hear feedback on sun java plugins anyone else having trouble with the newer version?? 1.3.1_01 works great btw.......... :cool:
  6. Barra

    Barra Guest


    I've tried to install an earlier version of Java but the problem is still there.

    The problem surfaces only the webpage javascript calls for a new window to open.
  7. sphere

    sphere Guest

    Problem Fixed

    Go to the Start menu, then Run and type in

    regsvr32 urlmon.dll

    then click OK

    this will register the dll file, then it should work :rolleyes:

    Hope that fixes it

  8. Barra

    Barra Guest

    Thanks again for the advice but I have been down that road and used that command to no effect. I just wish I could remember what was altered in My system to cause this, as it has only been doing it for about 2 weeks now.

  9. sphere

    sphere Guest


    Have you tried a system restore?

    Programs > Accessories > System Tools > System Restore

    Then you can restore your system back to how it was before the problem started.

    Also, I don't know if you have tried, but see if you can repair IE6 from the add/remove programs. If it's not there go to Program Files\Internet Explorer\Setup and run setup.exe.

    Hope that helps

  10. Barra

    Barra Guest


    Cannot install IE6 again as it detects the newer version and ends the installation.

    I disabled system restore


    Edit : After running some simple tests with parent and child windows on my PC - it appears the error returning to me is that the specified module cannot be found on a particular line.......

    It would seem that it is the module that was in the script.

    "<button onclick="'child.htm', 'newwin', 'width=700,height=500')">Open a child window</button> "
  11. Lactic.Acid

    Lactic.Acid Guest

    Not sure if you can do it or not, but try running the IE setup and try to add/remove components or repair install, and see if you can remove the MS JVM and reinstall it. Also, make sure you search the microsoft knowledge base for a solution for's very possible it's a known bug.
  12. Barra

    Barra Guest

    I haven't been able to find anywhere to repair IE6 and I certainly cannot re-install IE6 without re-installing XP.
    I've looked into the Microsoft Knowledge base and there appears to be a problem similar to mine but there is no fix that I can get at this point.;en-us;Q314209

    I couldn't even get the text to appear on the child window so this is where the problem differs.


    I'll probably reinstall Xp sometime soon anyway - it's starting to fill up with Junk.


  13. kanector

    kanector Guest

    You need to re-register the following 6 dll files:

    regsvr32 Shdocvw.dll
    regsvr32 Shell32.dll
    regsvr32 Oleaut32.dll
    regsvr32 Actxprxy.dll
    regsvr32 Mshtml.dll
    regsvr32 Urlmon.dll

    That should sort it out for you.