Help with Apache

Discussion in 'Windows Desktop Systems' started by Alvy, Mar 21, 2003.

  1. Alvy

    Alvy Guest

    I have setup my Web server (Apache) and everything works fine when I access http://localhost or any other files in the root.

    However, other people are unable to access anything on my web server... it seems that it only accepts conncetions from me...

    What should I check?
    I run BlackICE PC Protection as a firewall, do I need to unblock any ports?
     
  2. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    You must allow incomming traffic on TCP port 80. If you also have a router you must forward port 80 there as well.
     
  3. Alvy

    Alvy Guest

    HMm

    unblocked the port and still it doesn't work... strange

    any other suggestions?
     
  4. Piett

    Piett ...will circle this city

    Messages:
    528
    Location:
    Calgary, Alberta
    is your XP firewall on?
     
  5. Alvy

    Alvy Guest

    Nope its off =D
     
  6. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    You must have missed something. Maybe you must actively ALLOW traffic INCOMMING on port 80 rather than just unblocking it? Does the firewall log any attempted traffic on port 80?

    And I take it you are directly connected to the Internet, no routers, not other computers no nothing in between? An easy way to check (sorta) is to make sure your IP isn't 192.168.*.* or 10.*.*.*.
     
  7. Alvy

    Alvy Guest

    Yeap, I'm directly connected to the internet.

    How do I ALLOW INCOMING traffic to port 80? What I did for BlackICE PC Protection was to Add It under Advanced Firewall Settings:
    From All Addresses
    Port 80
    Type: TCP
    Mode: Accept


    I was wondering if this has anything to do with
    Internet File Sharing or NetBIOS Neighbourhood as I have those 2 disabled in BlackICE.
     
  8. Kevin Ar18

    Kevin Ar18 OSNN Senior Addict

    Messages:
    300
    As a quick test, turn off all firewalls and see if they can get through just to make sure it definitely is the firewall.
     
  9. Alvy

    Alvy Guest

    Hmm still can't work, so I guess its something in Windows or the httpd.conf file ... anyone knows what I should check now? =D

    Thanks for all the help so far
     
  10. Kevin Ar18

    Kevin Ar18 OSNN Senior Addict

    Messages:
    300
    Take a look in the httpd.conf and do a search for "listen" and make sure it is not set to "localhost" or some other IP address.
     
  11. Alvy

    Alvy Guest

    It was set at

    Listen 80

    I changed it to

    Listen 0.0.0.0:80

    but it still doesn't work =/

    Thanks for your suggestion, but are there any possible things as to why it doesn't work?
     
  12. Kevin Ar18

    Kevin Ar18 OSNN Senior Addict

    Messages:
    300
    Whatever you do, don't do that. You are telling it to only listen for connections from the IP address 0.0.0.0 on port 80. That definitely means no one will be able to access it. You should proabably leave it like you had it before.

    In essence you don't want to be listening for only one IP address.

    Alternatively try commenting out Listen like so:
    #Listen 80
    I doubt that will do anything, however.

    P.S. try accessing your site using the following:
    http://127.0.01/
     
  13. Alvy

    Alvy Guest

    Yeah I tried uncommenting already... still doesn't give any results.

    And yeap, going to my own site works for me.
     
  14. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    That firewall setting sounds right to me. Pretty straight forward. :)

    Can you access it using you external IP instead of 127.0.0.1 or localhost?
     
  15. Alvy

    Alvy Guest

    Yeap I can get in from my external IP too..

    Damn =D This is frustrating.