Hard Drive Reading Constantly, how to stop???

Discussion in 'Windows Desktop Systems' started by shoulin, May 25, 2007.

  1. shoulin

    shoulin OSNN Addict

    Messages:
    146
    Hello, i havent posted in a loong time but here it goes...


    Since i installed vista a while back i have had this annoying issue. The HDD just reads and reads at random times ....(i have a Raptor X so its loud as **** when it does it)

    i have indexing disabled, i was wondering if there is anything else i could do or disable to get it to stop doing that?


    Thanks in advance :)

    System Info:
    ------------------------------------
    AMD Athlon 4600 64bit x2 (939)
    Some Asus Mobo (nforce 410/430 chipset)
    Nvidia 7900GT 256mb
    2gig DDR PC3200
    150gig Raptor X 10,000rpm HDD
    D-Link DWL-510G Wireless PCI card
     
  2. fitz

    fitz Just Floating Along Staff Member Political User Folding Team

    Messages:
    4,076
    Location:
    Chicagoland
    Hey shoulin

    It's been mentioned in passing in various threads before.. namely here and here

    The name of the culprit would be superfetch which, if you read through the previous threads and will be mentioned here again, is a feature in Vista that treats system memory as a cache and will read data that Vista thinks is used often from the HD into memory so that it is ready to access via memory instead of reading from the slower HD.

    It actually works fairly well and is fairly intelligent. But, it can be a nuisance. You can disable the service if you wish..
     
  3. shoulin

    shoulin OSNN Addict

    Messages:
    146
    ok thanks for the info, every post i went to said u could disable it but not how...

    I just ran "services.msc" and disabled it from there...

    ... i bought a 10,000rpm drive with 2.9ms fetch time to cut down on loading, i didnt need this annoying vista feature hehe


    thanks again
     
  4. fitz

    fitz Just Floating Along Staff Member Political User Folding Team

    Messages:
    4,076
    Location:
    Chicagoland
    And that would be the way to disable it. :)