Firewall Trouble

Discussion in 'Windows Desktop Systems' started by Capricorn, Nov 28, 2003.

  1. Capricorn

    Capricorn OSNN Senior Addict

    Messages:
    379
    It seems that no matter which of the free Firewalls I use I have trouble sending mail using Outlook or Outlook Express. I have no trouble receiving mail. I set up to allow both Outlook and Outlook Express, but it makes no difference. As soon as I disable the Firewall the mail goes fine. Is there any chance that the Firewalls are being caused trouble by my Modem/Router Hardware Firewall?
     
  2. Enyo

    Enyo Moderator

    Messages:
    1,338
    Ensure that outlook is permitted to access outbound port 110 TCP.

    Your e-mail communication may also be intercepted by your anti-virues.

    For example in the case of NAV it will intercept the mail and scan it before sending it on. In NAVs case ccApp.exe requires a rule allowing ports 25 TCP and 110 TCP outbound.
     
  3. Erbmaster

    Erbmaster Moderator Folding Team

    Messages:
    1,195
    Location:
    Middle Of Nowhere - UK
    ^^What he said^^
    ....It's prolly yer AV filtering the mail.
     
  4. Capricorn

    Capricorn OSNN Senior Addict

    Messages:
    379
    Thanks Guys, as soon as I disable the Firewall everything works fine. I had a call from a friend the other day, saying that he couldn't send mail, I told him to disable his Firewall (Kerio 2.1.5) and it worked for him as well.
     
  5. Erbmaster

    Erbmaster Moderator Folding Team

    Messages:
    1,195
    Location:
    Middle Of Nowhere - UK
    You have misunderstood what was said.,
    Reread. You shouldn't have to disable your firewall to read mail! :eek:
     
  6. Capricorn

    Capricorn OSNN Senior Addict

    Messages:
    379
    I don't think I misread anything. The anti virus is still running fine, and mail is both being sent and received, as long as the Firewall is Disabled. I uninstalled my Firewall, as soon as I reinstall I will take Enyo's advice and configure the settings as he suggested. I am running Avast anti virus which I have had no trouble with.
     
  7. Erbmaster

    Erbmaster Moderator Folding Team

    Messages:
    1,195
    Location:
    Middle Of Nowhere - UK
    I see,
    I just thought you were running round offering advice to your friends to disable firewalls to read mail. My mistake
    No harm done then :D
     
  8. Capricorn

    Capricorn OSNN Senior Addict

    Messages:
    379
    I sorted the problem with mail. It was the Firewall not asking me about the anti virus checking mail. It was set to ask, but wasn't asking, it was just blocking. I set it to allow and it seems fine.

    However now I find that I cannot upload files to my Web Server. It allows me to access the Server Files, but when I try to upload it is getting blocked. If I disable Firewall I can upload files OK. I have checked the settings and my FTP software is set to allow, and when I try to upload I cannot see any applications being blocked. Any ideas?
     
  9. koko

    koko Got Root?

    Messages:
    577
    Location:
    Columbia, S.C.
    ftp uses port 21 usually. open port 21 in your firewall and everything should work fine.