explorer thinks im in 265 colour mode - help!

Discussion in 'Windows Desktop Systems' started by meglamaniac, May 31, 2002.

  1. meglamaniac

    meglamaniac Guest

    I run my desktop at 1024x768, 16bit (the best my graphics card can do).
    A couple of hours ago, I went into TweakUI and changed the shortcut setting under the explorer item to show no arrow on the icon.
    Explorer proceded to rebuild the icon cache as expected - however, NOT as expected, everything came out as if it was in 256 colour mode (yuk)! Also, the desktop wallpaper - while still displayed in hi-colour - is very badly rendered now with lots of visible banding (its a JPEG) which wasn't there before.
    The problem applies to the desktop, explorer and internet explorer - bascily anything thats part of the explorer shell.
    Everything else can see icons as hi-colour.
    If I switch down to 800x600 true colour, everything goes back to how it should be - change to 800x600 hi-colour, and the nice shaded icons are visible very breifly before the cache is rebuilt and the same icons reappear, but once more hideously dithered a la 256 colour mode.
    Explorer is using its 256 colour icon set as well (for folders and such).

    Of course, the first thing i tried was setting the shortcut setting back to normal, but it didn't work.
    I've tried everything I can think of, but can't find a way to get it back. In other accounts on the system, everything is fine, so this is obviously a per user registry setting.

    Now on WinME and so on, there was a setting in display options called "show icons using all possible colours". This is not present in XP, but I assume the registry setting still is (and I assume this is what has been altered).
    Can someone please tell me
    a) how to get it back
    b) where the damn registry key is so i can change it myself

    Please hurry - every minute brings me nearer to throwing up all over my keyboard in disgust...!

  2. meglamaniac

    meglamaniac Guest

    Right, I've fixed it - and because I'm such a nice person i'm gonna say how i did it in case anyone else gets the same problem.

    I was pratting about in the registry trying to find just ANYTHING that would give me a clue.
    As I allready knew it was a per user thing, I was looking in HKEY_CURRENT_USER, and as I expected it to be a shell setting I was in the Control Panel section.

    Much sifting through values and rubbing of eyes later (its now approaching 2am here, but I'm one of those people that just have to get little problems fixed as they drive me NUTS) I found the Desktop\WindowMetrics section and hit upon the key called Shell Icon BPP, which was set to 32.
    Hmmmmmmmmmm - looks like windows got confused again.
    Changed it to 16, rebooted and there it was, fixed - AND with no shortcut arrow since I'd set it back again after I realised that hadn't fixed it.

    So, if anyone else is being driven up the wall by this, here's the details (open up regedit to make the changes):
    Path: HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics
    Key: Shell Icon BPP
    Value: set it to 16, 24, or 32 depending on what your colour depth is

    Close regedit, reboot, and then send a suspisious package to microsoft because they managed to bugger up something so simple and waste my time at 2am in the morning.


  3. xsivforce

    xsivforce Prodigal Son Folding Team

    Texas, USA
    Thanks for posting your solution. You never know when someone else has or will have the same "problem". :)