explorer in XP PRO

Discussion in 'Windows Desktop Systems' started by Idle, Sep 9, 2003.

  1. Idle

    Idle Guest

    for some reason when i try to delete an .avi my explorer hoses up my mahcine. the explorer reaches upto 90,000k and eventuallt locks up. any ideas???
     
  2. J05H

    J05H Guest

    Hello:

    I have two ideas.

    1)
    If you have WinZip installed, I would recommend removing it from the context menu of "all files". By default, WinZip will scan the entire contents of the file (I am assuming it is a large AVI), which can cause long delays and perhaps crashes. It is simple to disable: First, open WinZip. Click Options, Configuration. Click the System tab. Under "Explorer Shell Extension", uncheck "Use shell extension". Click OK. Close WinZip and try to delete again. (To undo, follow steps and re-check the "Use shell extension")

    2)
    I've known this to sometimes occur when explorer tries to fetch a thumbnail image to preview the video. This generally displays along the left. To disable this preview window, go to the folder in which your .AVI file resides. Click "Tools", "Folder Options". Click "Use windows classic folders". Then click OK. Try to delete the file again. (To undo this change, follow the same steps and select "Show common tasks in folders" instead of "Use windows classic folders")
     
  3. Un4gIvEn1

    Un4gIvEn1 Moderator

    Messages:
    1,084
    Let me be the first to say...

    Welcome to the forums J05H
     
  4. Idle

    Idle Guest

    this seems to only happen in the My Documents folder then to My Music. I dont know how i got here because this drive is for the OS and i have back up drives here. the mdei player its recognizing is RealOne player. I am running Windows XP. meaning that wouldnt help about changing the thumnail view and also i dont have winzip. i have WinRAR. But i do aprreciate the help JOSH
     
  5. Idle

    Idle Guest

    it also says that the file is in use. but there is nothing running.
     
  6. JJB6486

    JJB6486 Retired Mod Political User

    Messages:
    1,207
    Location:
    West Lafayette, IN, USA
    Try deleting it in safe mode. Press F8 RIGHT after the POST beep, select "Safe Mode" then "Windows XP Professional"

    JJB
     
  7. Idle

    Idle Guest

    kul that worked. booting into safe mode and it did delete it. thank you
     
  8. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
  9. o0RaidR0o

    o0RaidR0o OSNN Addict

    Messages:
    119
    Location:
    S.E. Florida
    You may not find that particular string here is another proven workaround:

    There is a problem that XP exhibits in deleting or moving broken AVI files...it won't let you!

    The reason is when an AVI file is clicked on/highlighted, shmedia.dll by default reads the entire contents of the file before allowing any access to the file.

    Basically what this means is: as soon as you right click a broken avi file, shmedia.dll hangs and won't allow further file access to delete the broken file. Pretty screwed up...but

    THERE IS A FIX!!!

    -Simply delete the following registry key to prevent Explorer from loading shmedia.dll in response to file queries on these files.

    "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{87D62D94-71B3-4b9a-9489-5FE6850DC73E}\InProcServer32 "

    It worked for me after not having the aforementioned value in my reg.

    Good Luck :)